Unable to upload an in-house Android application to Symantec App Center
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Unable to upload an in-house Android application to Symantec App Center

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Article ID: 160934

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Updated On:

Products

Symantec Products

Issue/Introduction

After building an Android app with the ADT plugin for Eclipse, an error occurs when attempting to upload the app to App Center.

Could Not Upload : Unable to process app. Please double-check that you provide a valid app. 

Cause

Google Developer forums had a post with this issue. While the issue was not present upon uploading to App Center, it was observed by developers trying to upload apps to the Play Store.

Here is that forum post:

https://code.google.com/p/android/issues/detail?id=46311 (Form: Android Open Source Project - Issue Tracker)

 

Resolution

The issue was fixed in the ADT plugin versions R22 and up. Please download the a version of ADT that meets this criteria as laid out in the following article:

http://developer.android.com/tools/sdk/tools-notes.html

 

Applies To

App Center 4.4.x

Android Developers Tools (ADT) - plugin version 21.0.1 and lower.

Android OS. v4.x