CCS_web console does not load

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Article ID: 160825

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Updated On:

Products

Control Compliance Suite Windows

Issue/Introduction

The Control Compliance Suite (CCS) Web Console will not load in a web browser even when attempted on the Application Server machine.

Internet Explorer cannot display the web page.

Attempts to start the Windows Process Activation Service result in message: Windows could not start the Windows Process Activation Service on <computername>. Error 2: The system cannot find the file specified. OR Error 3: The system cannot find the path specified.

Cause

The root cause is due to a non-existent path for the IIS Application Pools.

The non-existent path causes the Windows Process Activation Service (WAS) to fail to start when triggered by the World Wide Web Publishing Service (W3SVC) starting. Since the W3SVC is dependent on the WAS the W3SVC will also fail to start causing the CCS web console to fail to load.

Resolution

It is possible that a security administrator has reconfigured the default path of the Web Application Pools to point to a different path.

This configuration can be confirmed by examining the contents of the registry key, HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\WAS\Parameters\ConfigIsolationPath.  Confirm that the path value specified in that string value exists and that LocalSystem has 'Full control' security permissions to the path specified.

If the above registry value does not exist check that the IIS Application Pools default path exists and that LocalSystem has 'Full control' permissions on the directory at C:\inetpub\temp\apppools\.

Once the path and permissions are confirmed attempt to restart the Windows Process Activation Service and if it starts without error, start the WWW Publishing Service. The CCS Web console should now display.