Unable to reach Enforce User Interface (UI) "HTTP error 404 - ORA-12505:TNS:listener does not currently know of SID given in connect descriptor"
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Unable to reach Enforce User Interface (UI) "HTTP error 404 - ORA-12505:TNS:listener does not currently know of SID given in connect descriptor"

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Article ID: 160748

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Updated On:

Products

Data Loss Prevention Enforce

Issue/Introduction

Unable to reach Enforce User Interface (UI) and the Monitor Controller Service stops minutes after starting.

The following errors may be seen in their respective logs:

Web Browser Display

  • 404 Error.

VontuManager.log:   

  • com.vontu.model.DatabaseConnectionException: org.apache.ojb.broker.PersistenceBrokerException: Used ConnectionManager instance could not obtain a connection.

VontuMonitorController.log:  

  • ERROR: PersistenceBrokerException during the execution of the query: Used ConnectionManager instance could not obtain a connection.
  • ORA-12505, TNS:listener does not currently know of SID given in connect descriptor.

localhost.currentdate.log

  • java.lang.RuntimeException: Manager: Database is not accepting connections, or bad Model.properties file.​

Cause

The above errors suggest that Data Loss Prevention (DLP) may have lost connection to the protect database. It is possible that the Oracle listener is not configured properly for the Protect instance, or the connection is being rejected due to a failure to login the Protect account.

Resolution

The following issues may cause the errors listed above:

  • The Protect TNS Listener instance is no longer valid.
  • The TNS Listener Service is not running.
  • The Oracle Protect user account has been locked by Oracle due to too many failed login attempts.
  • The Oracle Protect user password has expired.

To narrow down the issue which may be relevant for an environment, follow these steps:

  1. Attempt to identify where the failure in connection to the Oracle database lies.  The best method for pursuing this is to attempt a SQL Plus session as the Protect user from the Enforce Server.  Take note of any messages returned from Oracle if login fails, and remedy as necessary.
  2. Login to the Oracle database as the System account and view any possible holds on the protect user account.
  3. Review any sessions created by the protect user in Oracle and terminate them. Restart DLP services.
  4. If a connection to the database is unable to be established from the Enforce server due to a TNS issue, ensure that the TNS Listener service has started and a valid instance for Protect is running.
    • If there is no valid instance, or the Protect instance seems erroneous, follow the steps listed in the relevant Data Loss Prevention Oracle Installation Guide for the version of DLP running.