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Mails are getting queued up on the upstream MTA

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Article ID: 160660

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Updated On:

Products

Data Loss Prevention Network Prevent for Email Data Loss Prevention

Issue/Introduction

Mails are getting queued up on the upstream MTA

The issue gets resolved once SMTP prevent service is restarted and the queue on upstream MTA gets cleared.

Cause

While analyzing the SmtpPrevent_operational0.log found the below entries:

12/Jun/12:08:32:31:506-0500 [SEVERE] (SMTP_CONNECTION.5203) Forward connection error (tid=27 cid=875 mta=cluster8out.us.messagelabs.com reason=null)

12/Jun/12:08:32:31:506-0500 [SEVERE] (SMTP_CONNECTION.5210) All forward hosts unavailable (tid=27 cid=<> reason=No available forward hosts)

12/Jun/12:08:32:31:506-0500 [INFO] (SMTP_CONNECTION.1205) Service connection closed (tid=27 cid=875 local=10.39.157.67:25 remote=10.100.224.51:8679 messages=0 time=20s)

Resolution

The above errors indicate that SMTP prevent is not able to connect to the next downstream MTA - which may have stopped accepting connections from DLP.

It's possible the settings on that MTA need to be checked - such as limits to connections, or timeouts for existing connections.