Database connection reset errors
search cancel

Database connection reset errors

book

Article ID: 160604

calendar_today

Updated On: 06-16-2025

Products

Data Loss Prevention Enforce

Issue/Introduction

Unable to login to the UI at times, and during normal operations in the UI, users experience RSOD.

When Users are unable to login, they will get this error;

J_security check page in address bar

 

ALERT LOG SHOWS;

Fatal NI connect error 12170.

  VERSION INFORMATION:
 TNS for 64-bit Windows: <Version > - Production
 Oracle Bequeath NT Protocol Adapter for 64-bit Windows: <Version > - Production
 Windows NT TCP/IP NT Protocol Adapter for 64-bit Windows: <Version > - Production
  Time: 29-APR-2011 08:21:22
  Tracing not turned on.
  Tns error struct:
    ns main err code: 12535
   
TNS-12535: TNS:operation timed out
    ns secondary err code: 12560
    nt main err code: 505
   
TNS-00505: Operation timed out
    nt secondary err code: 60
    nt OS err code: 0
  Client address: (ADDRESS=(PROTOCOL=tcp)(HOST=<server>)(PORT=<port>))
    nt main err code: 505
   
TNS-00505: Operation timed out
    nt secondary err code: 60
    nt OS err code: 0
  Client address: (ADDRESS=(PROTOCOL=tcp)(HOST=<server>)(PORT=<port>))
Fri Apr 29 08:21:16 2011

 

local host log

 

 

18 May 2011 13:36:02,360- Thread: 27 SEVERE [com.vontu.manager] Unable to perform login for user: <username>
Cause:
org.apache.ojb.broker.PersistenceBrokerException: org.apache.ojb.broker.PersistenceBrokerSQLException:
* SQLException during execution of sql-statement:
* sql statement was 'SELECT A0.roleID,A0.name,A0.description,A0.isDeleted FROM UserRoleMapping M_N, Role A0 WHERE (M_N.userID = ?) AND M_N.roleID = A0.roleID'
* Exception message is [Io exception: Connection reset]
* Vendor error code [17002]
* SQL state code [08006]
org.apache.ojb.broker.PersistenceBrokerSQLException:
* SQLException during execution of sql-statement:
* sql statement was 'SELECT A0.roleID,A0.name,A0.description,A0.isDeleted FROM UserRoleMapping M_N, Role A0 WHERE (M_N.userID = ?) AND M_N.roleID = A0.roleID'
* Exception message is [Io exception: Connection reset]
* Vendor error code [17002]
* SQL state code [08006]
java.sql.SQLRecoverableException: Io exception: Connection reset
java.net.SocketException: Connection reset
org.apache.ojb.broker.PersistenceBrokerException: org.apache.ojb.broker.PersistenceBrokerSQLException:
* SQLException during execution of sql-statement:
* sql statement was 'SELECT A0.roleID,A0.name,A0.description,A0.isDeleted FROM UserRoleMapping M_N, Role A0 WHERE (M_N.userID = ?) AND M_N.roleID = A0.roleID'
* Exception message is [Io exception: Connection reset]
* Vendor error code [17002]
* SQL state code [08006]

 

Resolution

It is possible that there is some lag time between the Enforce box and the Oracle Server. Have the Customer address any firewall issues that may be contributing to the lag time.