search cancel

After upgrading the Traffic page indicates "Servers marked with this icon require upgrading"

book

Article ID: 160483

calendar_today

Updated On:

Products

Data Loss Prevention Enforce Data Loss Prevention

Issue/Introduction

After upgrading your Enforce Server, red exclamation marks ("!") are showing against at least one of the protocols in Traffic report saying the servers needs to be upgraded.

However, the Enforce and Detection Servers are all on the same version, and seem properly upgraded.

"Servers marked with this icon require upgrading. Until upgraded, only minimal functionality will be available and a server restart will disable all functionality."

 

Environment

DLP 15.x

Cause

The "Protocols" page should not have displayed the message that "Server needs to be updated". This message was meant for the "System => Server and Monitors => Traffic" landing page but due to a bug the message got displayed on the "Protocol" page as well. The message is a cosmetic UI displaying problem and does not have any effect on the actual working of the product.

Resolution

The bug was fixed in DLP 16.0
The traffic report drill down page now checks if the server version is lower than installed DLP version only on "System => Server and Monitors => Traffic" landing page i.e., when listing servers and not on the protocols page.

 

Additional Information

This error is just a cosmetic problem that does not have any effect on the actual working of the product.

Further verification could be to make a policy change for one of these two monitors and then generate incidents that would only happen given that policy.  If the incidents appear in Enforce, then the Detection Server is not down-level from the Enforce Server’s perspective and properly operating at the same version level.

Attachments