Error "Failed to contact the scan manager. Make sure Vontu Monitor Controller service is running error when starting a scan".
search cancel

Error "Failed to contact the scan manager. Make sure Vontu Monitor Controller service is running error when starting a scan".

book

Article ID: 160415

calendar_today

Updated On:

Products

Data Loss Prevention Enforce

Issue/Introduction

Attempting to start a Discover scan results in a Red Bar Of Death (RBOD) along with the error "Failed to contact the scan manager. Make sure Vontu Monitor Controller service is running."

 

 

 

The following error is displayed as a Red Bar Of Death (RBOD):

An unexpected error has occurred. This could be due to one of the following: 1) Your session timed out and you selected a link that is no longer valid, 2) You used the browser back or forward button and placing the system into an inconsistent state, or 3) The system experienced a temporary problem.

The following error will be found inside the localhost.date.log:

org.quartz.JobExecutionException: java.rmi.UnmarshalException: Error unmarshaling return header; nested exception is: 
    java.net.SocketTimeoutException: Read timed out
java.rmi.UnmarshalException: Error unmarshaling return header; nested exception is: 
    java.net.SocketTimeoutException: Read timed out
java.net.SocketTimeoutException: Read timed out

org.quartz.JobExecutionException: java.rmi.UnmarshalException: Error unmarshaling return header; nested exception is: 
    java.net.SocketTimeoutException: Read timed out [See nested exception: java.rmi.UnmarshalException: Error unmarshaling return header; nested exception is: 
    java.net.SocketTimeoutException: Read timed out]
    at com.vontu.manager.filescan.target.schedule.ResumeScanJob.execute(ResumeScanJob.java:42)
    at org.quartz.core.JobRunShell.run(JobRunShell.java:213)
    at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:557)

Environment

Data Loss Prevent Network Discover

Cause

The errors indicated in this article could be caused by Vontu MonitorController not having enough memory to assign the Network Discover scans to the detection server.

Resolution

To resolve this issue MonitorController memory can be increased to allow it to utilize more memory on the detection server.

  1. Go to SymantecDLP\Protect\Config
  2. Open VontuMonitorController.conf file
  3. Increase the following settings:
    1. wrapper.java.initmemory = 128 to wrapper.java.initmemory = 1024
    2. wrapper.java.mazmemory = 1024 to wrapper.java.initmemory = 2048
  4. Save the changes
  5. Recycle Vontu Monitor Controller service

NOTE: The following settings above will be dependent on resources available to the Enforce server.

Once adjusting VontuMonitorController memory settings does not resolve the issue then adjusting the ScanManager timeout settings inside the ScanManager.properties. The following steps below will assist in adjusting this timeout.

  1. Go to SymantecDLP\Protect\Config
  2. Open ScanManager.properties file
  3. Uncomment the property timeout=15000 (remove the #) at the end of the file and change the value to 60000 ie. timeout = 60000
  4. Save the changes
  5. Recycle Vontu Monitor Controller service