A blank page appears after entering User ID and password in Enforce UI console
search cancel

A blank page appears after entering User ID and password in Enforce UI console

book

Article ID: 160378

calendar_today

Updated On:

Products

Data Loss Prevention Enforce Data Loss Prevention

Issue/Introduction

Nothing appears (blank page) after entering the User ID and password in the Enforce console.

Problem Summary

  1. You open the Enforce login UI for DLP
  2. Enter your User ID and Password and press enter.
  3. Nothing appears, the webpage remains blank.

 

The Localhost.log has an entry like this one:

SEVERE [com.vontu.javatoxml.JavaToXMLTranslator]
Java to XML Debug Output
------------------------
JXD: resource:/com/vontu/manager/report/table/jxd/ReportTable.jxd
Line: 25
Column: 182
Context Stack:
 com.vontu.manager.report.incidentlist.network.NetworkIncidentListTable == com.vontu.manager.report.incidentlist.network.NetworkIncidentListTable@9d88b83
Instruction Trace:
 PUSH_CONTEXT; Line: 25; Column: 182; context: new com.vontu.condition.sql.query.DefaultRowIterator(getRowIterator()); iterate: yes; skipNull: yes
 POP_CONTEXT; Line: 23; Column: 13
 LOOP_END; Line: 23; Column: 13
 ELEMENT_END; Line: 23; Column: 13; name: column-meta-data
 ATTRIBUTE; Line: 22; Column: 70; name: defaultSortOrder; value: getDefaultSortOrder(); skipNull: no
 ATTRIBUTE; Line: 21; Column: 86; name: defaultSortColumn; value: isDefaultSortColumn() ? 'yes' : 'no'; skipNull: no
 ATTRIBUTE; Line: 20; Column: 48; name: label; value: getLabel(); skipNull: no
 ATTRIBUTE; Line: 19; Column: 46; name: type; value: getType(); skipNull: no
 ATTRIBUTE; Line: 18; Column: 66; name: sortColumnName; value: getSortColumnName(); skipNull: no
 ATTRIBUTE; Line: 17; Column: 52; name: name; value: getColumnName(); skipNull: no
 ELEMENT_START; Line: 16; Column: 85; name: column-meta-data
 LOOP_BEGIN; Line: 16; Column: 85
 PUSH_CONTEXT; Line: 16; Column: 85; context: getReportHeaderColumns(); iterate: yes; skipNull: no
 POP_CONTEXT; Line: 14; Column: 13
 LOOP_END; Line: 14; Column: 13
 ELEMENT_END; Line: 14; Column: 13; name: table-meta-data
 PCDATA; Line: 13; Column: 30; value: getValue()
 ATTRIBUTE; Line: 11; Column: 45; name: name; value: getKey(); skipNull: no
 ELEMENT_START; Line: 10; Column: 89; name: table-meta-data
 LOOP_BEGIN; Line: 10; Column: 89
 PUSH_CONTEXT; Line: 10; Column: 89; context: getTableMetaData().entrySet(); iterate: yes; skipNull: no
 ATTRIBUTE; Line: 8; Column: 88; name: exceedsMaximumAllowableRows; value: exceedsMaximumAllowableRows(); skipNull: no
 VARIABLE_DECLARATION; Line: 6; Column: 69; name: metaDataColumns; value: getRowMetaDataColumns()
 VARIABLE_DECLARATION; Line: 5; Column: 56; name: reportColumns; value: getColumns()
 ELEMENT_START; Line: 3; Column: 31; name: report-table
 LOOP_BEGIN; Line: 3; Column: 31
 PUSH_CONTEXT; Line: 3; Column: 31; context: this; iterate: yes; skipNull: no
Cause:
com.vontu.javatoxml.expression.ExpressionException: com.vontu.manager.report.incidentlist.network.NetworkIncidentListTable.getRowIterator
java.lang.reflect.InvocationTargetException
java.lang.NullPointerException
com.vontu.javatoxml.expression.ExpressionException: com.vontu.manager.report.incidentlist.network.NetworkIncidentListTable.getRowIterator
 at com.vontu.javatoxml.expression.MethodCallExpression.evaluate(MethodCallExpression.java:141)
 at com.vontu.javatoxml.expression.FunctionExpression.evaluateParameters(FunctionExpression.java:49)
 at com.vontu.javatoxml.expression.InstantiationExpression.evaluate(InstantiationExpression.java:35)

Resolution

  1. Ensure connectivity is fine between Enforce and Oracle database. Try pinging from the Enforce to the Oracle server. Also, test with tnsping protect<where protect is the service name>.
  2. If there is no connectivity issue between the Enforce and Oracle database server, restart the Symantec services in the order below:

    Stopping services in DLP 15.5 and later
                1. Symantec DLP Detection Server Controller Service
                2. Symantec DLP Incident Persister Service
                3. Symantec DLP Manager Service
                4. Symantec DLP Notifier Service

    Starting services in DLP 15.5 and later
                1. Symantec DLP Notifier Service
                2. Symantec DLP Manager Service
                3. Symantec DLP Incident Persister Service
                4. Symantec DLP Detection Server Controller Service

  3. Log in again to Enforce.