Error "ORA-12154: TNS: could not resolve the connect identifier specified" while trying to login to Enforce Server database
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Article ID: 160000
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Updated On:
Products
Data Loss Prevention EnforceData Loss PreventionData Loss Prevention Oracle Standard Edition 2
Issue/Introduction
You get the Error:- "ORA-12154: TNS:could not resolve the connect identifier specified" while trying to login to Enforce Server database database (e.g., the "protect" database for DLP).
This error can also be seen when creating the DLP Oracle user or the DLP Upgrade User.
Cause
This error may occur with the use of special characters in the password.
Resolution
An Oracle password has the following rules:
Passwords must be from 1 to 30 characters long.
Passwords cannot contain quotation marks.
Passwords are case sensitive.
A Password must begin with an alphabetic character.
Passwords can contain only alphanumeric characters and the underscore (_), dollar sign ($), and pound sign (#).
Oracle strongly discourages you from using $ and #.
A Password cannot be an Oracle reserved word (eg: SELECT).