Upgrade Wizard for DLP 11.1.2 on windows fails to start

book

Article ID: 159784

calendar_today

Updated On:

Products

Data Loss Prevention Enforce

Issue/Introduction

You are trying to upgrade DLP Enforce from 11.0 or 11.1 to 11.1.2 using the upgrader. When you start the upgrade wizard by using the Enforce UI or running the start_upgrade_wizard.bat directly, the wizard never comes up on port 8300. You notice that one of the only logs in the upgrade directory is a catalina log, containing the following error message:

Feb 29, 2012 3:19:52 AM org.apache.catalina.startup.Catalina start
SEVERE: Catalina.start:
LifecycleException:  service.getName(): "Catalina";  Protocol handler start failed: java.io.IOException: Keystore was tampered with, or password was incorrect

Resolution

This error suggests that something has happened to the .keystore file located in the Vontu\Protect\tomcat\conf directory. Check the directory to see if there is only one keystore file or multiple. If there are multiple, like someone made a backup, temporarily rename the current .keystore file to something else.  Then rename the oldest backup to ".keystore".

Then try the wizard again. If it works, after upgrading return the files to the way they were and recycle the Vontu Manager service.

If the issue persists,contact Symantec Support for assistance.

Note that you cannot use the Upgrade Wizard when upgrading from 11.0 to 11.1.2 - for more on this known issue, please see KB 55179.