SPSSService ("SymantecSharePointScan") cannot be started and stays in "stopping" status on Symantec Protection for SharePoint Server 6.0.x

book

Article ID: 159376

calendar_today

Updated On:

Products

Scan Engine Protection for SharePoint Servers

Issue/Introduction

Symantec Protection for SharePoint Server 6.0.x service ("SymantecSharePointScan" \ Symantec.Sharepoint.SPSSService.exe) doesn't start and remains in a "stopping" state right after starting it or reboot.
 

Log Name: Application
Source: Symantec Protection for SharePoint Servers Service
Date: 18/06/2014 09:09:39
Event ID: 0
Level: Error
Computer: SPSSserver.Local
Description:
The following information was included with the event:
Module=RTCommand.GetScanEngineInfoList | Exception message=There is an error in XML document (0, 0). | Inner exception message=Root element is missing. | Stack= at System.Xml.Serialization.XmlSerializer.Deserialize(XmlReader xmlReader, String encodingStyle, XmlDeserializationEvents events)
at System.Xml.Serialization.XmlSerializer.Deserialize(Stream stream)
at Symantec.Sharepoint.Service.RTCommand.Service.GetScanEngineInfoList(String spssMachine)

Cause

Corrupt SPSS service caused by XML file corruption.
 

Resolution

This issue is resolved in SPSS 6.0.5. For earlier versions, the following workaround is the quickest way to resolve the problem:

  1. Go to Start > Run > cmd.exe
  2. Run following command to stop the SPSS service properly: "taskkill /IM Symantec.Sharepoint.SPSSService.exe /F"
  3. Delete the file "C:\Program Files\Common Files\Symantec Shared\SharePointEngine\SPSSLocalConfig.xml"
  4. Run a repair install on the SPSS installation (Control Panel > Symantec Protection for Sharepoint Servers" > Repair).
  5. The "SPSSLocalConfig.xml" file will be recreated.
  6. Start the Sharepoint service from Services manager.

If the above fails, the problem might be due to incorrectly assigned database permissions of the Sharepoint service account. Please refer to the SPSS Best Practice Technote for more information:

http://www.symantec.com/business/support/index?page=content&id=TECH185102

As a last resort, SPSS can be uninstalled and reinstalled:

  1. Uninstall SPSS via the Control Panel (appwiz.cpl), and reboot the server
  2. Install SPSS again
  3. On each Symantec Protection Engine (SPE) server (if there are more than one): re-register ICAP to the primary IP of the SPE server, and restart the SPE service after that in order to have Protocol setting applied.