Windows System Assessment Scan Fail to launch
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Windows System Assessment Scan Fail to launch

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Article ID: 159330

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Updated On:

Products

Patch Management Solution

Issue/Introduction

Windows System Assessment Scan Fail to launch.

  • Clients are unable to download or execute the Patch Windows Assessment Scan Package.
  • The scan fails to launch, and client logs indicate an attempt to access a file: STPatchAssessment.log.

-Error message observed:

Failed to launch assessment scan for provider: Traditional
 
-Warning message in logs:
 
Block 0 (7/69) is invalid for file 'C:\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\Software Delivery\{6D417916-467C-46A7-A870-6D86D9345B61}\cache\STPatchAssessment.log'

The Windows System Assessment Scan fails because the client expects STPatchAssessment.log as part of the package, but by default, this file is not included in the Patch Assessment Scan Package. The error occurs when the client attempts to validate or execute the scan using this nonexistent log file.

Environment

ITMS 8.8

Cause

Customer had selected "Run from the server" in the Symantec Management Agent Settings - Target (Settings > All Settings > Agents/Plug-ins > Symantec Management Agent > Settings > Symantec Management Agent Settings - Target > All Desktop computers (excluding 'Site Servers') > Software Delivery > Download and Run Options. 

This caused the client to run the Windows Assessment Scan from the SMP from the WindowsVulnerabilityScan folder on the Notification Server and created the scan / log files - STPatchAssessment.log and STPatchAssessment.xml. These files updated the Windows System Assessment Scan package and that new package needed to be replicated out to the clients; however, the updated package is invalid and will not download.

These files are regularly located at: <drive>://Program Files\Altiris\Altiris Agent\Agents\Software Management\Software Delivery\{6D417916-467C-46A7-A870-6D86D9345B61}\cache folder

Resolution

1.Uncheck the option  "Run from the server" in the Symantec Management Agent Settings - Target (Settings > All Settings > Agents/Plug-ins > Symantec Management Agent > Settings > Symantec Management Agent Settings - Target > All Desktop computers (excluding 'Site Servers') > Software Delivery > Download and Run Options.. It is recommended this option be unchecked for any computer - desktop or server.

 

2. Delete the two files STPatchAssessment.log and STPatchAssessment.xml in the <drive>://Program Files/Altiris/Patch Management/Packages/WindowsVulnerabilityScan folder.

3. Run the Scheduled Task NS.PackageRefresh to recreate the Snapshot for the package.

4. Allow the clients to get an Updated Configuration request.