SEPM Embedded database "Assertion failed: 200505" and Checksum failure errors

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Article ID: 159314

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Updated On:

Products

Endpoint Protection

Issue/Introduction

The Symantec Endpoint Protection Manager (SEPM) embedded database service is shutting down. The db\err.log file contains many errors with "Checksum failure on page ...".

 

04/03 16:42:54. *** ERROR *** Assertion failed: 200505 (12.0.1.3554)[sem5]
Checksum failure on page 273125
04/03 16:44:18. *** ERROR *** Assertion failed: 200505 (12.0.1.3554)[sem5]
Checksum failure on page 273125
04/03 16:53:02. *** ERROR *** Assertion failed: 200505 (12.0.1.3554)[sem5]
Checksum failure on page 273125

 

Cause

The database is corrupt. The corruption is likely related to a hardware issue, such as bad blocks or corruption on the physical disk.

 

Resolution

  • Investigate disk corruption with checkdisk (including a scan for bad sectors using chkdsk/r), and further with tools from the hard drive manufacturer.
  • Perform a check of other hardware on the machine, including the memory/RAM.
  • Restore the SEPM database from a previous backup.

 

See also:
Best Practices for Disaster Recovery with the Symantec Endpoint Protection Manager
http://www.symantec.com/docs/TECH160736
 

If there is no database backup, and the SEPM is able to run for a short while before the database service shuts down, then it might be possible to export individual policies (firewall, anti-virus etc.) from the console to re-import on a fresh rebuilt SEPM.