When Clicking A Servicedesk Attachment Link, the Proper Category Containing the Attachment is Not Displayed

book

Article ID: 159173

calendar_today

Updated On:

Products

Workflow Solution ServiceDesk

Issue/Introduction

 In Servicedesk or Workflow, When clicking on the link to open an attachment from the Process View, using the Process Documents Webpart,  the link resolves to the Documents Tab Main Page.

It also highlights the AppDocsRootCategory folder of that page in the tree view, instead of displaying the specific category view for the attachment.  See the screen shot below.
 
 

 N/A

Cause

The web page that controls the display of the category view, cannot properly parse the category tree correctly when the number of categories to be display exceeds the number configured in Admin>Master Settings>Document Management>Max Categories 

To Display In Document Tree.

Resolution

 
Workaround:
The value set in Admin>Master Settings>Document Management>Max Categories To Display In Document Tree can be set to a value larger than default (50).

A suggested value might be the number of processes generated in a week or a month. Changing the master setting to a larger value may have some performance implications in a larger environment.

Applies To

Servicedesk 7.5, ServiceDesk 7.5 SP1

Pointfix:
Additionally a fix was added to Workflow 7.5 SP1 rollup branch for SD 7.5 SP1, build 7.5.3001.94.
Please contact support to request the rollup.

Attachments