After installing the DLP agent to a client where the Symantec Management Agent is installed the Notification Server logs start filling up with 'The target item for the client message does not exist' errors

book

Article ID: 159150

calendar_today

Updated On:

Products

Management Platform (Formerly known as Notification Server)

Issue/Introduction

After installing the DLP agent to a client where the Symantec Management Agent is already installed the Notification Server logs start filling up with 'The target item for the client message does not exist' errors which reference the guid {c3a8d66c-a4eb-4bbf-b0fe-5cfbb4616f3a}

 

ITMS 7.5 Errors in the logs (7.1 Errors will reference the same guid but may look a bit different)

The target item for the client message does not exist: from: 6a849a1e-cf92-4d51-8572-7ff640877b12, to: c3a8d66c-a4eb-4bbf-b0fe-5cfbb4616f3a 
-----------------------------------------------------------------------------------------------------
Date: 3/4/2014 11:54:02 AM, Tick Count: 277675203, Host Name: <HOSTNAME>, Size: 568 B
Process: AeXSvc (1380), Thread ID: 64, Module: AeXSVC.exe
Priority: 1, Source: ClientMessageProcessing
File: C:\ProgramData\Symantec\SMP\Logs\a.log

 

Unable to process message intended for: . Target item does not support IItemMessaging interface. 
-----------------------------------------------------------------------------------------------------
Date: 3/4/2014 11:54:02 AM, Tick Count: 277675203, Host Name: <HOSTNAME>, Size: 525 B
Process: AeXSvc (1380), Thread ID: 64, Module: AeXSVC.exe
Priority: 1, Source: ClientMessageProcessing
File: C:\ProgramData\Symantec\SMP\Logs\a.log

 

Cause

After the DLP agent is installed and becomes integrated with the Symantec Management Agent it begins sending information to the NS. If the NS does not have the DLP software installed it will not know what to do with this information and will create the errors in the logs.

This Technote also applies to customers who had the DLP Integration Component in NS version 7.1, but upgraded to NS 7.5 or higher. Since the DLP Integration Component is no longer supported in NS 7.5, the steps in this Technote are necessary for those who've upgraded their NS and are experiencing this issue.

Resolution

Note: If NS has been upgraded to 7.5 or higher, the steps in Scenarios 1 and 3 will be required to resolve this issue.

 

Scenario 1: SMP agent installed after DLP Agent install

This scenario covers the use case where the customer has already installed the DLP agent and then rolls out the Altiris agent on the endpoint. In such a case by default, DLP agent will auto-register itself with the SMP agent. To prevent the auto registration perform one of the following steps, depending on the version of the DLP agent installed.
A) Version of DLP agent is 10.5.3 or lower:
1.       In Enforce for each Endpoint Server go to the "Server Details" page
2.       Click "Endpoint Settings" button. This will take you to the page where the Endpoint advanced settings can be edited.
3.       Set the value of the setting "SMP.AUTO_ENABLE.int" to 0(zero) and save the changes. This setting stops automatic registration and unregistration.
 
B) Version of DLP agent is 11.0 or higher:
1.       In Enforce, go to the "Agents > Agent Configuration", then select the specific configuration for each group of endpoints exhibiting this issue.
2.       Click "Advanced Agent Settings" button. This will take you to the page where the advanced settings particular to each configuration can be edited.
3.       Set the value of the setting "SMP.AUTO_ENABLE.int" to 2 and save the changes. This setting (available from DLP agent v11) unregisters the DLP agent if already registered.
With the above three steps performed, the DLP agent will not register itself with SMP agent when SMP agent gets installed.

 C) If your DLP Agents are on 11.x, but your Enforce Console is 12.5 or higher, the above Advanced Settings will not be available within the Enforce UI. In this case, Scenario 3 below will be required.

 

Scenario 2: DLP Agent installed after SMP agent has been installed

This scenario covers the use case where the customer already has SMP agent installed and the DLP agents are deployed on those endpoints. In such a case to prevent the DLP agent from sending inventory to the NS we need to perform the following additional steps after performing the steps listed in Scenario 1. The screen shots below enlist the steps that need to be followed in sequence
DLP IC SMP solution is required to follow the below steps.
1.       Launch the Agent management package settings page by navigating to the highlighted link. Create a new command line here by clicking on the "New" button as highlighted.

 
2.       Create the new command line.
 
 
3.       Clone the existing policy by clicking on the clone link. Enter the name of the new policy in the dialog box being shown as "Unregister DLP Agent".
 
4.       Enter the details of the new policy as shown in the below screen shot. Make sure the policy is enabled.
 
 
5.       After the policy has been run on the agent and all DLP Agent plug-ins have been unregistered, switch off the "Unregister DLP Agent" policy.

 

Scenario 3: Customer is not able to install DLP IC to perform the task of Agent un-registration

This use case covers the scenario where the customer is unwilling (or unable) to install DLP IC SMP solution solely for the purpose of "un registering" the DLP IC Agent plug-in.
Here there is no option but to run the utility RegDLPAgentmgmt.exe with the following command line on every endpointPrior to this the steps mentioned in Scenario 1 must be completed.
> RegDLPAgentmgmt.exe /u /s
This utility is not an official utility; it is bundled within the DLP IC SMP solution installer. To retrieve this utility, install the DLP IC SMP solution on a particular host. Then navigate to the following path to obtain this utility: %programfiles%\Altiris\DLP_IC\Agent_Registration.
 

If none of the above solutions work, please contact Technical Support for further information.

 

 

Applies To

 

ITMS 7.5 and 7.1

 

Attachments

Uninstall DLP Agent.zip get_app
SMA & DLP Agent Integration Behavior.docx get_app
RegDLPAgentmgmt.zip get_app