Edit Incident: String entered in the 'Affected User' or 'Set Owner' fields should be passed through to the search window when clicking the magnifying glass icon.

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Article ID: 159100

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Updated On:

Products

ServiceDesk

Issue/Introduction

Edit Incident: String entered in the 'Affected User' or 'Set Owner' fields should be passed through to the search window when clicking the magnifying glass icon.

Cause

Current behaviour forces users to retype whatever they had on the main form into the search field in the search subdialog.

Resolution

This issue is fixed in ServiceDesk 7.6.

Workaround:

As a workaround, making the following changes to the SD.IncidentManagementSimple.Classification workflow will resolve the issue:

  1. SD.IncidentManagementSimple.Classification project > Primary model > Edit Incident form
  2. Edit 'Search for Owner' button next to [Incident.Owner] textbox > User Interaction tab > Edit Model
  3. Add 'Copy Data Element to New Location' component after 'VarSearchtext [8]' with data type Text copied from VarOwner to VarSearchText
  4. Connect the newly added component to 'SearchUser' instead of directly to 'User Search Form'.
  5. Add 'Add New Data Element' component between 'VarSearchText [8]' and the newly added 'Copy Data Element' - Data Type: User; Variable name: VarSelectedUser
  6. Repeat steps 3-5 for the (currently mislabeled) 'Search for Owner' button next to [Incident.Affecteduser] textbox except with VarAffectedUser being copied to VarSearchText in step 3.

 

 

Applies To

 

ServiceDesk 7.5 SP1