Duplicate GUID issue in ec_alert Table for Monitor Solution

book

Article ID: 159047

calendar_today

Updated On:

Products

Monitor Agent for Unix/Linux Monitor Solution Notification Server Agent for Macintosh (Altiris) Monitor Pack for Servers Monitor Solution for Servers

Issue/Introduction

A duplicate GUID error in the ec_alert table referencing an issue with a primary key keeps showing up in the Server logs on the NS.  It can eventually cause alerts to stop triggering.

( Exception Details: System.Data.SqlClient.SqlException: Violation of PRIMARY KEY constraint 'PK_ec_alert'. Cannot insert duplicate key in object 'dbo.ec_alert'. The duplicate key value is (60b32377-7c0a-4f4f-82cc-182aae50595d)"
 

*Note the GUID referenced will be different and may be different every time the error occurs.

Cause

The cause of this issue is unknown at this time.

Resolution

This issue can be resolved by completely purging the tables ec_alert and ec_alert_pooled.

To purge the tables open Microsoft SQL Server Management Studio and run the following queries:

delete from ec_alert

delete from ec_alert_pooled

This should clear all of the data in the tables and allow the Event Console to function normally thereafter. 


Applies To

Windows Server 2008 R2

Symantec Management Platform 7.1 - 7.5