DS7.5 KNOWN ISSUE: When adding drivers to BootWiz, a very long delay may result in a console failure.

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Article ID: 158977

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Updated On:

Products

Deployment Solution

Issue/Introduction

Sometimes, when adding drivers to BootWiz either directly or via the console (under Settings | Deployment | Driver Management on the "Preboot" tab), it can take a very long time.  If the time exceeds 5 minutes, the console will return a failure and suggest looking at the logs for more information.

Cause

The root cause is being researched by Development.  There are several steps that BootWiz goes through to add drivers, and several delays that may show up in the logs, but we're not yet sure why it takes this long.

What we do know however is that there is a default web TimeOut of 5 minutes configured for pretty much every web page, and that if the process takes longer than this, it will timeout and an error returned to the screen.

Resolution

A solution is being worked on by Development.  Only work-arounds exist at this time.

We know that, as a general rule, Bootwiz will eventually run to completion and add the drivers. This can be verified by looking for the CUSTOM folder in BootWiz on the SMP server, generally found under Program Files\Altiris\Deployment\BDC\bootwiz\Platforms\WinPE\x64\Drivers\ (or x86).  If the drivers were copied here, the process most likely worked, even if there was an error on the screen.

To avoid the error:

  • Consider running BootWiz directly.  The process will still be long but the 32bit app doesn't timeout.
  • Consider increasing the timeout for the console.  This may hang the console longer but avoid the error.  It can be modified by editing the deployment "web.config" file under Program Files\Altiris\Deployment\Web.  Open the file, look for the line similar to: <httpRuntime executionTimeout="300" maxRequestLength="10000"/> and modify the timeout.  300 is 5 minutes, and we recommend trying 10 minutes or 600.