Control Compliance Suite - Application Server Service fails to start.

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Article ID: 158976

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Updated On:

Products

Control Compliance Suite Exchange Control Compliance Suite Windows

Issue/Introduction

The Application Server Service fails to start.

The log C:\Documents and Settings\All Users\Application Data\Symantec.CSM\Logs\AppServer\AppServer.Service.xxxxx.xxxxx.csv shows:

2014-02-17 11:52:48.320,2014-02-17 14:52:48.320,hostname,Error,Symantec.Core,AppserverService,1332,,8,Receive,,0,1,"RetryHelper.Call(Send) - failed [The socket connection was aborted. This could be caused by an error processing your message or a receive timeout being exceeded by the remote host, or an underlying network resource issue. Local socket timeout was '00:10:00'.], context [SendStreamsImpl], stop retry flag [False], failed retry counter [0 of 5] : System.ServiceModel.CommunicationException: The socket connection was aborted. This could be caused by an error processing your message or a receive timeout being exceeded by the remote host, or an underlying network resource issue. Local socket timeout was '00:10:00'. ---> System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host 

Looking at the error using WCF logging - it shows it was connecting to the Encryption Management Service on port 12468.
 

<Uri>net.tcp://hostname.domain.local:12468/Symantec.EncryptionManagement.DispatchProtocol/RemoteObject/netTcpCert</Uri> 

 
Looking at the Encryption Management Service logs (C:\Documents and Settings\All Users\Application Data\Symantec.CSM\Logs\EncryptionManagement) (in verbose) it shows: 
 

2014-02-17 11:52:48.320,2014-02-17 14:52:48.320,hostname,Warning,DispatchProtocol.Common,Symantec.CSM.EncryptionManagement.Service,604,,10,HandleError,,0,0,"FaultErrorHandler - Unhandled Exception: System.ServiceModel.Security.SecurityNegotiationException: A call to SSPI failed, see inner exception. ---> System.Security.Authentication.AuthenticationException: A call to SSPI failed, see inner exception. ---> System.ComponentModel.Win32Exception: The client and server cannot communicate, because they do not possess a common algorithm

 

That last error is key here: The client and server cannot communicate, because they do not possess a common algorithm

 

Cause

This error can be be caused by registry keys in:
 
Key:       [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\Schannel\Protocols\****\Server]
 
Value:   "Enabled"=dword:00000000  
 
The added value of "enabled=0" is non-standard and will prevent the use of the protocol - this protocol is used by CCS.
 
For more information on the function of these keys see: http://support.microsoft.com/kb/245030
 

Resolution

 Remove the registry key value:  "Enabled"=dword:00000000  (or set it to 1)

 


Applies To

CCS 10.5.1, CCS11

Windows: all supported versions