Policy not delivered automatically and manually to iOS device

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Article ID: 158922

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Updated On:

Products

Mobile Management

Issue/Introduction

Policies seem not to be delivered to device. Device is being targeted by the right policy. Policy contain multiple payloads. Policy contain EAS payload.

No payloads from the policy are being delivered.

 No error is displayed on the device. 

logs from the device console taken by iPCU show as follows:

Desc   : The profile EAS could not be installed.

Sugg   : An identical Exchange account already exists.

US Desc: The profile EAS could not be installed.

US Sugg: An identical Exchange account already exists.

Domain : MCProfileErrorDomain

Code   : 1009

Type   : MCFatalError

Params : (

EAS

)

...Underlying error:

NSError:

Desc   : An identical Exchange account already exists.

US Desc: An identical Exchange account already exists.

Domain : MCEASErrorDomain

Code   : 21005

Type   : MCFatalError

Extra info:

{

isPrimary = 1;

}

Cause

Apple/iOS prohibits multiple identical email accounts on an iOS device. When an identical Exchange ActiveSync is deployed to a device, an 'Error - Profile Installation Failed' error will be logged.

Resolution

 If an Exchange ActiveSync account already exists on the iOS device that is identical to the ActiveSync payload set to deploy via SMM. To resolve the error, either manually remove the existing email account from the device itself, or remove the EAS payload from the Policy. The EAS payload should be delivered in a separate policy for best practices.


Applies To

 SMM 7.2 all versions