Some Keyboards may not work at Preboot with Symantec Encryption Products

Some Keyboards may not work at Preboot with Symantec Encryption Products

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Article ID: 158897

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Updated On:

Products

Drive Encryption Desktop Email Encryption Encryption Management Server Endpoint Encryption File Share Encryption Gateway Email Encryption PGP Command Line PGP Key Management Server PGP Key Mgmt Client Access and CLI API PGP SDK

Issue/Introduction

Symantec Encryption products encrypt the drive and prevent the system from booting until a passphrase has been successfully entered.

There are some reports that keyboards may not work on certain hardware when attempting to enter the passphrase at Preboot.

 

Cause

There may be various causes for this, including some of the basic things you should check:

*Make sure you have disabled Quick/Fast boot in the BIOS as this will bypass the initialization of the USB ports and can keep the logic from loading during post.

*Some newer machines may need to XHCI mode enabled in the BIOS for USB ports.

*Some hardware may require a newer version of Symantec Encryption Desktop in order for these to work, and some versions may require different keyboard parameters to be configured.

*Some Keyboard layouts like French or Spanish may have issues whereas English does not have issues.

Resolution

Solution Scenario 1: Disable Fast Startup in Windows and Quick Boot in BIOS

In Windows, there is a Power Management setting called "Fast Startup":

This setting can affect how a system boots and could cause some unexpected behavior, such as keyboards not working properly at preboot, SSO not automatically logging in to Windows or other potential scenarios.
Disable this setting (uncheck) for best performance with Symantec Drive Encryption (Both SEE and PGP).

Check also the BIOS for any Fastboot/Quickstart/Quick boot settings.  Fast/Quick Boot/startup does not allow all peripherals to be loaded during the boot process and can sometimes prevent external keyboards from working.  It could also cause login failures, especially if USB 3.0 ports are being used.  Fast startup does not offer a noticeable increase in speed during the boot process and so disabling these will not cause any performance issues in most cases.  It may be necessary to disable both of these settings for benefits to be observed.

Note: Different BIOS vendors, such as Lenovo, Dell, or HP will call these boot settings differently.  For Dells as an example, disabling Fast Boot is sometimes called "Thorough".

HP BIOS:

 

 

Solution Scenario 2: Toggle XHCI USB (USB 3.0) setting

 

Solution Scenario 3: HP 600 G1 systems have had some issues when Symantec Encryption Desktop 10.4.2 is installed.  In order for this to be resolved, see article 161066 for more details.  As specified in the article, a command to enable a legacy boot option for this issue can be done.  If upgrading to SED 10.4.2 from a previous version, run the command before the upgrade, and during the upgrade, the parameters will remain intact.

This issue may be related to non-US keyboard layouts.

 

Solution Scenario 4: Keyboards on HP Z15/Z17 may not work at preboot with SED 10.4.2 clients when using non-US keyboard layouts.  A fix was included in Symantec Encryption Desktop 10.4.2 MP3 and above.

 

Solution Scenario 5: Keyboards on some HP systems, such as HP Z4 G4, or RTL8822CE, may not work at preboot with SED 10.4.2 MP3 and above with non-US/English keyboard layout.  This is an issue where the keyboard layout is not English. There may be other issues where the OS is English, but the locale settings are in non-US.  The Symantec Encryption software can detect the keyboard layout and set automatically and when this happens the keyboard may not work at preboot.  A possible solution for this is to configure the language in the BIOS configuration to match the locale being used.  For example, if French locale settings are being used, set the language in the BIOS to French.

To locate this setting, go into the HP bios via F10, Advanced, select the Keyboard Layout to "French" and then reboot the system.

If the locale is set to Spanish, then in the BIOS, change the language to Spanish and this may resolve the issue. 

Note: In some of these keyboards, external keyboards can work at preboot for non-US keyboards.


 

 

Additional Information