AD Import Rule stays at message "Task is starting" and doesn't move past trying to start

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Article ID: 158894

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Updated On:

Products

Management Platform (Formerly known as Notification Server)

Issue/Introduction

Customer reported that few days ago his AD Import Rules are not moving from the message "Task is starting".
The customer tried all of his AD Import Rules and all of them do the same. He even created a new AD Import Rule and it also stays in "Task is starting" message. The customer also mentioned that he has seen the rules in this state for a day without any progress.

 

 The NS logs (even with verbose entry on) shows just these entries:

Severity: 4
Critical: False
Date: 1/27/2014 2:34:51 PM
Tick Count: 389556078
Process: AeXSvc (1768)
Thread: 137
Module: AeXSVC.exe
Source: DirectoryImportTask::DoDirectoryImportTask
Description: Task is starting... (rule: {F0B49454-DE6F-434E-BF9C-BB8A56D63B95})

 

Severity: 4
Critical: False
Date: 1/27/2014 2:34:51 PM
Tick Count: 389556078
Process: AeXSvc (1768)
Thread: 137
Module: AeXSVC.exe
Source: DirectoryImportSettings::ConfigureImportRule
Description: Configuring import rule {F0B49454-DE6F-434E-BF9C-BB8A56D63B95}, server=MyServer.Domain.com, type=AD

 

Cause

 The Altiris Services needed a restart. It could be related with a “race condition” caused by some other process.

Environment

ITMS 7.5, 7.6, 8.0, 8.1

Resolution

 This issue can be solved by restarting the Altiris Services. After that is done, try starting one more time the desired AD Import Rule.