KNOWN ISSUE: Basic Inventory Dates for Mac Computers is not being replicated up to the Parent Server

book

Article ID: 158854

calendar_today

Updated On:

Products

Management Platform (Formerly known as Notification Server)

Issue/Introduction

Every time a Windows computer sends a basic inventory. The AeX AC Client Agent dataclass updates the "Data Last Received" date AND the "Data Last Changed" date. If you send back to back Basic Inventories, both dates change even though nothing has changed in the data. (All this is displayed in the Resource Manager, under views, inventory, basic inventory, AeX AC Client Agent, Status Tab.)

On a Mac Computer when a basic inventory is sent, the "Data Last Received" date is updated but if nothing has changed from the last basic inventory the "Data Last Changed" keeps its old date. So Windows computers and Mac Computers behave differently.
The first time a Hierarchy Replication is run, both the Windows computers and the Mac Computers basic inventory data is sent up to the parent server. When a subsequent Differential Hierarchy Replication takes place, the Windows Computers basic inventory is replicated to the Parent server and the Mac Computers basic inventory data is NOT sent up. If you clear the ForwardingHistorySummary table of all Mac Computer Resources then the latest Mac Computer basic inventory is replicated to the Parent server. (This is the customers workaround at the moment.) 

 

Cause

Known issue. AeX AC Client Agent dataclass is not replicating up if the "Data Last Changed" date in not updated when it should be replicating if the "Data Last Received" date is changed. Or if one of those two dates change.

The solution is to replicate Agent Data Class based on ModifiedDate as well as all the other criteria.

Resolution

Symantec has acknowledged that the above-mentioned issue is present in the current version of the product mentioned earlier on this article. Symantec is committed to product quality and satisfied customers.

Symantec currently plans to address this issue by including a fix in the next ITMS 7.1 SP2 MP1 Rollup: Rollup v9. Please be sure to refer back to this document periodically as any changes to the status of the issue will be reflected here. A link to the Release Notes will be added to this document when it becomes available. Please note that Symantec reserves the right to remove any fix from the targeted release if it does not pass quality assurance tests.  Symantec’s plans are subject to change and any action taken by you based on the above information or your reliance upon the above information is made at your own risk.

A pointfix is available for this issue that can be installed ONLY on top of ITMS 7.1 SP2 MP1 Rollup v7. See attachments.

 

REQUIREMENT

 

SMP 7.1 SP2 MP1 with rollup v7 installed

 

HOW TO INSTALL THIS POINTFIX

 

1.     Retrieve files from the archive to the NS hard drive.

2.     Run as administrator PFinstaller.EXE, click on ‘Install files’ button

3.     Old binaries will be automatically backed up to the same location where PFinstaller is and replaced with the new ones.

 

CHANGES MADE

Agent Data Class now replicates basing on ModifiedDate as well as on the other criteria.

 


 

THIS HOTFIX HAS THE FOLLOWING KNOWN ISSUES: 

 

Description

TECH214053

SMA Agent details dates in RM are not populated on Parent NS for replicated ULM computers

 

HOW TO UNINSTALL 

1.    Make sure that Backup subfolder is located in PFinstaller directory
2.    Execute PFInstaller.exe with administrative privileges (right-click > Run as administrator).
3.    Accept UAC (User Account Control) prompt, select Uninstall Files.

 

 

Applies To

 ITMS 7.1 SP2 MP1 Rollup v7

Attachments

Pointfix_eTrack3353610_7_1_SP2_MP1_1_v7.zip get_app