Clients do not register, accessing the URL for register.aspx throws error "Unable to read install directory from Software\Altiris\eXpress\TaskServerSetup"

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Article ID: 158732

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Updated On:

Products

Task Server

Issue/Introduction

 When clients attempt to register, they stall and never connect to a task server. Enabling debug logs for the Symantec Management Agent and finding the URL for the request "Register.aspx" and pasting it into a browser returns the following IIS error:

 

<event date='XX/XX/2013 XX:XX:XX.XXXXXXX -XXXXX' severity='1' hostName='XXXXXXXX' source='Altiris.TaskManagement.Common.XmlHttp.BaseXmlHttpCallback.LogResponseException' module='Altiris.TaskManagement.Common.dll' process='w3wp.exe' pid='XX' thread='XX' tickCount='X' >

  <![CDATA[The handler 'Register.aspx' failed to process request.System.Exception: We cannot service this request because the web application failed to initialize. ---> System.Exception: Unable to configure remoting during Application Start ---> System.Exception: Unable to read install directory from Software\Altiris\eXpress\TaskServerSetup

 

 

 

 System.Exception: Unable to read install directory from Software\Altiris\eXpress\TaskServerSetup

 

 

Cause

 The application pool the ClientTaskServer is using is running as a 32 bit process.

 

 

Resolution

 Open IIS 7 Manager, expand the server on the left, then click on Application Pools. Select the Application Pool the ClientTaskServer is utilizing, and click Advanced Settings on the right. Find 'Enable 32 bit Process' and set it to false.

Close the manager, and do an IISreset.

 

 


Applies To

 Any x64 bit Site Server

SMP 7.5