Workflow Server to ProcessManager Portal Connection fails on ServiceDesk 7.5 upgrade

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Article ID: 158714

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Updated On:

Products

ServiceDesk

Issue/Introduction

When attempting to upgrade to ServiceDesk 7.5 SP1 from a previous version you encounter an error with the prerequisite step "Workflow Server to ProcessManager Portal Connection".  This step fails and you cannot proceed with upgrade.

From the ServiceDesk Setup log you'll see an error similar to the following error:

INFO 15:32:20,426 4 Symantec.ServiceDesk.Installation.Core.SystemCheck - Executing system check [30] with description [Workflow Server to ProcessManager Portal Connection]
DEBUG 15:32:31,927 4 Symantec.ServiceDesk.ModuleFramework.PmServiceFacade - Logging into ProcessManager using userman service at [https://<servername>:80/ProcessManager/userman/userman.asmx]...
ERROR 15:32:34,424 4 Symantec.ServiceDesk.ModuleFramework.PmServiceFacade - Could not create ProcessManager session: [The underlying connection was closed: An unexpected error occurred on a send.]
System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a send. ---> System.IO.IOException: The handshake failed due to an unexpected packet format.
   at System.Net.Security.SslState.StartReadFrame(Byte[] buffer, Int32 readBytes, AsyncProtocolRequest asyncRequest)
   at System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer, AsyncProtocolRequest asyncRequest)
   at System.Net.Security.SslState.CheckCompletionBeforeNextReceive(ProtocolToken message, AsyncProtocolRequest asyncRequest)
   at System.Net.Security.SslState.StartSendBlob(Byte[] incoming, Int32 count, AsyncProtocolRequest asyncRequest)
   at System.Net.Security.SslState.ForceAuthentication(Boolean receiveFirst, Byte[] buffer, AsyncProtocolRequest asyncRequest)
   at System.Net.Security.SslState.ProcessAuthentication(LazyAsyncResult lazyResult)
   at System.Net.TlsStream.CallProcessAuthentication(Object state)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Net.TlsStream.ProcessAuthentication(LazyAsyncResult result)
   at System.Net.TlsStream.Write(Byte[] buffer, Int32 offset, Int32 size)
   at System.Net.PooledStream.Write(Byte[] buffer, Int32 offset, Int32 size)
   at System.Net.ConnectStream.WriteHeaders(Boolean async)
   --- End of inner exception stack trace ---
   at System.Web.Services.Protocols.WebClientProtocol.GetWebResponse(WebRequest request)
   at System.Web.Services.Protocols.HttpWebClientProtocol.GetWebResponse(WebRequest request)
   at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
   at LogicBase.Core.Ensemble.UserMan.Userman.LoginUser(String email, String password)
   at Symantec.ServiceDesk.ModuleFramework.PmServiceFacade.RefreshSessionId()
INFO 15:32:34,494 4 Symantec.ServiceDesk.Installation.Core.SystemCheck - Finished executing system check [30]. Return message is [Unable to connect]
WARN 15:32:34,494 4 Symantec.ServiceDesk.Installation.Core.SetupProgram - Prerequisite check [DetectPortalConnection] failed: Unable to connect
WARN 15:32:34,509 1 Symantec.ServiceDesk.Installation.App - Prerequisite check [Workflow Server to ProcessManager Portal Connection] failed and there is no remediation program specified



 

Cause

In this instance, in Local Machine Info Editor, the URL value for the default (local) server was configured with https://<servername>, however the use HTTPS box was not checked. 

Resolution

Modifying the URL value to be http://<servername> corrected the failure with the prerequisite check.


Applies To

ServiceDesk 7.5