User needs to fill-in the mandatory details in the profile when logging into Software Portal for the first time
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Article ID: 158673
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Updated On:
Products
Software Management Solution
Issue/Introduction
Is there a way to remove the need to fill out User details when a user loads the Software Portal for the first time? This would be especially important since having an email address listed is required to make changes to the users's profile settings in the software portal.
Environment
Software Management Solution 8.x
Cause
By default user needs to provide the "Full Name" and "Email address" in Software Portal.
Resolution
The user's email address should be populated in Active Directory. If so, the following steps should be followed to import the user into the Symantec_CMDB database.
In Active Directory verify that the user's email address is entered.
In the Symantec Management Console, click Actions> Discover> "Import Microsoft Active Directory".
Under "Resource Import Rules", select the default "Import User resources" rule and click on "Run the selected import rule now (Update Import) (Note: If it is a new user, then run the Full import).
Go to Manage> Users. Right-click on the user which is newly created/updated then click on Resource Manager. Click on View > Inventory. Navigate to Inventory > User Data > Global User General Details to view the User Details with Email.
Now login to a client computer, open the Software Portal provide the required credentials to login and then verify that the Profile has the required fields populated automatically.
In addition, this information is stored in the Inv_Symantec_Common_Software_Portal_User_General_Details table in the database.