Unable to build the client configuration XML for advertisement with guid Software Update Plug-in Install for Windows x64. Reason: Did not get a row for Software Delivery Advertisement "Software Update Plug-in Install for Windows x64" from the SWD tables.

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Article ID: 158617

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Updated On:

Products

Management Platform (Formerly known as Notification Server)

Issue/Introduction

Attempt to push Software Management Solution Plug-in using the policy "Software Management Solution Plug-in Install (ac2afa31-475b-4eee-9f28-19bbba1f11fb)" fails with the following error.

Source: Altiris.NS.AgentManagement.PolicyRequest.LoadItemPolicy
Description: Unable to generate policy XML for item: Software Update Plug-in Install for Windows x86 (874a6bd1-879e-4a00-9e3c-58586d44721f)
( Exception Details: Altiris.NS.Exceptions.AeXException: Unable to build the client configuration XML for advertisement with guid Software Update Plug-in Install for Windows x86 (874a6bd1-879e-4a00-9e3c-58586d44721f). Reason: Did not get a row for Software Delivery Advertisement "Software Update Plug-in Install for Windows x86", Guid = Software Update Plug-in Install for Windows x86 (874a6bd1-879e-4a00-9e3c-58586d44721f) from the SWD tables. ---> Altiris.NS.Exceptions.AeXException: Did not get a row for Software Delivery Advertisement "Software Update Plug-in Install for Windows x86", Guid = Software Update Plug-in Install for Windows x86 (874a6bd1-879e-4a00-9e3c-58586d44721f) from the SWD tables. At Altiris.NS.StandardItems.SoftwareDelivery.AdvertisementItem.OnBuildClientConfigXml2(Guid workstationGuid, XmlNode requestDocumentElement, XmlTextWriter xmlBuilder)
--- End of inner exception stack trace ---
at Altiris.NS.StandardItems.SoftwareDelivery.AdvertisementItem.OnBuildClientConfigXml2(Guid workstationGuid, XmlNode requestDocumentElement, XmlTextWriter xmlBuilder)
at Altiris.NS.StandardItems.Policies.ClientConfigPolicy.GetConfigXml(Guid resourceGuid, String requestXml)
at Altiris.NS.AgentManagement.PolicyRequest.<>c__DisplayClass4.<LoadItemPolicy>b__0(IDatabaseContext ctx)
at Altiris.Database.DatabaseContext`1.PerformWithDeadlockRetryHelper(Int32 retries, Boolean inTransaction, Getter`1 getContext, Action`1 action, Action`1 retry)
at Altiris.Database.DatabaseContext`1.PerformWithDeadlockRetry(Int32 retries, Boolean startNewTransaction, IsolationLevel isolationLevel, Boolean independentContext, Action`1 action, Action`1 retry)
at Altiris.Database.DatabaseContext`1.PerformWithDeadlockRetry(Int32 retries, Boolean startNewTransaction, Action`1 action, Action`1 retry)
at Altiris.NS.ContextManagement.DatabaseContext.PerformWithDeadlockRetry(Int32 retries, Action`1 action, Action`1 retry)
at Altiris.NS.AgentManagement.PolicyRequest.LoadItemPolicy(String request, Guid requestGuid, Guid resourceGuid, Guid hostGuid, Guid policyGuid, String& policy, String& policyHash, Guid& category, Int32& priority, Boolean& canCache, ISet`1& requiredPermissions, ISet`1& filterCollections) )
( Exception logged from:
at Altiris.Diagnostics.Logging.EventLog.ReportException(Int32 severity, String strMessage, String category, Exception exception)
at Altiris.NS.Logging.EventLog.ReportException(Int32 severity, String strMessage, String category, Exception exception)
at Altiris.NS.AgentManagement.PolicyRequest.LoadItemPolicy(String request, Guid requestGuid, Guid resourceGuid, Guid hostGuid, Guid policyGuid, String& policy, String& policyHash, Guid& category, Int32& priority, Boolean& canCache, ISet`1& requiredPermissions, ISet`1& filterCollections)
at Altiris.NS.AgentManagement.PolicyRequest.LoadItemPolicies(String request, String configVers, Guid hostGuid, List`1 idents, SortedDictionary`2& policies, SortedDictionary`2& hashes)
at Altiris.NS.AgentManagement.PolicyRequest.GetPolicies(String request)
at Altiris.Web.NS.Agent.GetClientPolicies.ProcessRequest(String& request, Byte[]& clientConfigData, String& clientConfigXml, Boolean& compress)
at System.RuntimeMethodHandle._InvokeMethodFast(Object target, Object[] arguments, SignatureStruct& sig, MethodAttributes methodAttributes, RuntimeTypeHandle typeOwner)
at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean skipVisibilityChecks)
at System.Delegate.DynamicInvokeImpl(Object[] args)
at Altiris.Common.Threading.LocalThreadPool.InvokeCallback(Object state)
at Altiris.Common.Threading.LocalThreadPool.ExecuteUserWorkItem(UserWorkItem workItem)
at Altiris.NS.Threading.NSThreadPool.ExecuteUserWorkItem(UserWorkItem workItem)
at System.Threading.ExecutionContext.runTryCode(Object userData)
at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at Altiris.Common.Threading.LocalThreadPool.ExecuteUserWorkItemInContext(UserWorkItem workItem)
at Altiris.Common.Threading.LocalThreadPool.ThreadPoolProc(Object threadStartParameter)
at System.Threading.ThreadHelper.ThreadStart(Object obj)
)
( Extra Details: Type=Altiris.NS.Exceptions.AeXException Src=Altiris.NS.StandardItems

Inner Extra Details: Type=Altiris.NS.Exceptions.AeXException Src=Altiris.NS.StandardItems )

 

Cause

The issue is due to the presence of cloned policies after upgrade.

Resolution

1. Take a backup of the existing policies and settings by exporting the same.
2. Disable the existing cloned policies
    3a. Assign the default policies to computers/ filters, if not already assigned.
    4a. Enable the default policies.
    5a. Run "Complete resource membership update" task and wait for the clients/agents to receive the new policies. Once the agents receive the new default policies, check whether the error still remains.

If the above does not fix the issue, execute the following steps:

    3b. Delete the existing cloned policies.
    4b. Execute the process for repairing Patch Management as per: http://www.symantec.com/docs/HOWTO47868
    5b. Assign the default policies to computers/ filters.
    6b. Enable the default policies.
    7b. Run "Complete resource membership update" task and wait for the clients/agents to receive the new policies.

Once the agents receive the new default policies, check whether the error still remains.


Applies To

ITMS 7.1.2 MP1