Java LiveUpdate fails with Return code = 232 after upgrading to Symantec Protection Engine 7.x from Scan Engine 5.2.7 or earlier

book

Article ID: 158585

calendar_today

Updated On:

Products

Protection Engine for Cloud Services Scan Engine

Issue/Introduction

After upgrading to Symantec Protection Engine 7.x over top of an older Scan Engine 5.2.7 or earlier, Java LiveUpdate will no longer download virus definitions.

Error seen in liveupdt.log file from affected system:

Oct 11, 2013 4:42:12 PM jlue7: GfsPkcs7SignedFile::verifyCertPath():  objCertJ.buildCertPath failed to get cert path.
 at jluez.a(DashoA5380)
 at jluez.a(DashoA5380)
 at jluez.a(DashoA5380)
 at jluez.a(DashoA5380)
 at jluez.a(DashoA5380)
 at jlubb.a(DashoA5380)
 at jlubb.a(DashoA5380)
 at jluba.a(DashoA5380)
 at jluba.a(DashoA5380)
 at jluba.b(DashoA5380)
 at jluf5.i(DashoA5380)
 at jluf5.d(DashoA5380)
 at jluf5.a(DashoA5380)
 at com.symantec.liveupdate.LiveUpdate.computeAvailableUpdates(DashoA5380)
 at com.symantec.liveupdate.LiveUpdate.a(DashoA5380)
 at com.symantec.liveupdate.LiveUpdate.main(DashoA5380)

Oct 11, 2013 4:42:12 PM No valid guard/signature files were found.
Oct 11, 2013 4:42:12 PM
Oct 11, 2013 4:42:12 PM The Java LiveUpdate session did not complete successfully.
Oct 11, 2013 4:42:12 PM Return code = 232
Oct 11, 2013 4:42:12 PM

============================================================
<IdsJluCommandLine><-c D:\Program Files\Symantec\Scan Engine\liveupdate.conf [ -p SPE AV Definitions for x86-windows -v 7.0 -l SymAllLanguages -t virusdef -z 2012042816 ] >
<IdsJluCommandLineCharacterSet><UTF-8>
<IdsPVLListing1>
<IdsPVLListing2>
<IdsJluSesaVersionCompatible>
<IdsJluToSesaAgentNotInstalled>
<IdsJavaVersion><1.7.0_40>
<IdsJavaLiveUpdateVersion><3.0><27>

Cause

Scan Engine versions 5.2.7 and earlier used Java LiveUpdate version 3.0 which does not always get updated when installing Symantec Protection Engine 7.x over top of the old Scan Engine product.

This situation can be seen at the end of the installation process, where the installer will say that it has completed succesfully but that not all components were able to be updated, and will specifically call out Java LiveUpdate. Without realizing there is an issue the person installing the product will click okay and the installer dialog box will go away.

At that point the Symantec Protection Engine product will not be able to update virus definitions on that box.

A review of the Liveupdt.log will show the error listed above, and that it is using the older Java LiveUpdate version 3.0.37 instead of the newer version 3.9.1.28.
 

Resolution

The only solution is to remove Symantec Protection Engine and then the Java LiveUpdate version 3.0 product, and re-install Symantec Protection Engine.