Symantec Protection Engine service will not start after installation on Solaris 11

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Article ID: 158577

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Updated On:

Products

Scan Engine AntiVirus for Caching Protection Engine for NAS

Issue/Introduction

After a new successful installation of Symantec Protection Engine on a Solaris 11 server, the "symcscan" daemon will not start.

Output of startup process showing error using the command : truss -aef -o /tmp/symcscan_start.out /etc/init.d/symcscan start

270/2:  lwp_create() (returning as new lwp ...) = 0
270/1:  lwp_continue(2)     = 0
270/2:  setustack(0xFD0702C8)
270/2:  schedctl()     = 0xFD1D4040
270/1:  lwp_detach(2)     = 0
270/2:  sysconfig(_CONFIG_NPROC_ONLN)   = 3
270/2:  stat64("/opt/SYMCScan/bin/libjvm.so", 0xFD18B308) Err#2 ENOENT
270/2:  stat64("./libjvm.so", 0xFD18B308)  Err#2 ENOENT
270/2:  stat64("/lib/libjvm.so", 0xFD18B308)  Err#2 ENOENT
270/2:  stat64("/usr/lib/libjvm.so", 0xFD18B308) Err#2 ENOENT
270/2:  stat64("/lib/secure/libjvm.so", 0xFD18B308) Err#2 ENOENT
270/2:  stat64("/usr/lib/secure/libjvm.so", 0xFD18B308) Err#2 ENOENT
270/2:  open("/usr/lib/locale/en_US.UTF-8/LC_MESSAGES/SUNW_OST_SGS.mo", O_RDONLY) Err#2 ENOENT
270/2:  open("/usr/lib/locale/en_US.UTF-8/LC_MESSAGES/SUNW_OST_OSLIB.mo", O_RDONLY) Err#2 ENOENT
270/2:  stat64("/opt/SYMCScan/bin/libjvm.so", 0xFD18B308) Err#2 ENOENT
270/2:  stat64("./libjvm.so", 0xFD18B308)  Err#2 ENOENT
270/2:  stat64("/lib/libjvm.so", 0xFD18B308)  Err#2 ENOENT
270/2:  stat64("/usr/lib/libjvm.so", 0xFD18B308) Err#2 ENOENT
270/2:  stat64("/lib/secure/libjvm.so", 0xFD18B308) Err#2 ENOENT
270/2:  stat64("/usr/lib/secure/libjvm.so", 0xFD18B308) Err#2 ENOENT
270/2:  brk(0x00152000)     = 0x00000000
270/2:  brk(0x00154000)     = 0x00000000
270/2:  stat("/opt/SYMCScan/bin/ssejvm.config", 0xFD18BDE0) = 0
270/2:  open("/opt/SYMCScan/bin/ssejvm.config", O_RDONLY) = 3
270/2:  brk(0x00154000)     = 0x00000000
270/2:  brk(0x00156000)     = 0x00000000
270/2:  read(3, " - D j a v a . l i b r a".., 8192) = 77
270/2:  read(3, 0x00152BA0, 8192)   = 0
270/2:  close(3)     = 0
270/2:      Incurred fault #6, FLTBOUNDS  %pc = 0x00000000
270/2:        siginfo: SIGSEGV SEGV_MAPERR addr=0x00000000
270/2:      Received signal #11, SIGSEGV [default]
270/2:        siginfo: SIGSEGV SEGV_MAPERR addr=0x00000000

Cause

During installation of the Symantec Protection Engine product the JavaJRELib= path statement in the "symcscan.sh" file did not get populated with the correct information for the Java lib path.

Resolution

To determine the Java lib path information on your system please use the following command: find / -mount -name 'libjvm.so' -exec ls -ld {} \; >/tmp/find_jvm.txt

The path you are looking for in the text output should be something like the following "/usr/jdk/instances/jdk1.6.0/jre/lib/sparc/client", and is dependant on the version of Java installed on your system.

Once you have determined the correct information, please make a backup copy of the /opt/SYMCScan/bin/symcscan.sh file before editing this file, and add the correct path information. The edited line should look something like the following: JavaJRELib=/usr/jdk/instances/jdk1.6.0/jre/lib/sparc/client

Restart the "symcscan" daemon using the following command "/etc/init.d/symcsan start", and verify that the issue has been resolved.