Patch Management Restart Status Report times out.

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Article ID: 158495

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Updated On:

Products

Patch Management Solution for Windows

Issue/Introduction

Restart Status Report fails to render data and times out with errors in the SMP Log Viewer.

On the Console > Home > Patch Management > Exception Handling > Computers Requiring Restart

Error excerpt from SMP Log Viewer:

Failure running Report 'Restart Status'. Please check the configuration of the query.

Exception Details: Altiris.DataSource.Exceptions.DataSourceRunException: Timeout Expired ---> System.Data.SqlClient.SqlException: Timeout expired. The timeout perior elapsed prior to completion of the operation or the server is not responding.

Cause

Bloated database tables, or lack of indexing / maintenance on the database, is most likely the cause; however, research found the scripted Stored Procedure behind this report could be enhanced for better performance.

Resolution

Work through the following:

  1. Run the attached updated Stored Procedure: 'spPMCore_RebootStatusReport7_0.sql' against the Symantec_SMDB database in the Microsoft SQL Server Management Studio
    1. Advisory: This script is written to 'Create' the Stored Procedure and will throw an error upon running until the old Stored Procedure is renamed for archive purposes.
      1. Example: Go to the Databases > Symantec_CMDB > Programmability > Stored Procedures; locate the Stored Procedure: 'dbo.spPMCore_RebootStatusReport7_0.sql'
        1. Highlight in the left pane; right-click > Rename: add the extension; _old
    2. Best practice: Always ensure a recent backup of the database was performed before updating any database items.
       
  2. Ensure the Database Maintenance / Health is in order:
    1. Utilize the SSE Tool found on KM: HOWTO60787
    2. Utilize the SMP Diag Tool found on KM: TECH202997

 

 

Applies To

 

Patch Management 7.1 SP2 MP1.x

Attachments

spPMCore_RebootStatusReport7_0.sql get_app