Feature Request: Digital Signature for Symantec Encryption Desktop .msi is not valid if customized

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Article ID: 158491

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Updated On:

Products

Encryption Management Server

Issue/Introduction

When downloading the Symantec Encryption Desktop client from Symantec Encryption Management Server, if the customize option is selected, the browser may report the signature corrupt or invalid.  A solution is needed that stops the warning messages from occurring.

Warnings reported by Internet Explorer:

Internet Explorer 9 - "The program was reported unsafe."
Internet Explorer 10 and 11 - "The signature of PGPDesktop_en-US.msi is corrupt or invalid." 
 

Cause

The client is originally signed by a verified certificate authority when created.  This client unmodified (no customization checkbox) will not report the above warnings.  However, the signature depends on the .msi file being unmodified.  As soon as customization is added, the signature is then no longer valid.  This does not change the operation of the installer, it is still valid, it just does not have a signature that matches the customization.  This error can be safely disregarded when downloading the client from the Symantec Encryption Management Server.

 

Resolution

Symantec Corporation is committed to product quality and satisfied customers.  This Feature Request is currently being considered by Symantec Corporation to be addressed in a forthcoming version of the product. 

 

Technical Support filed a Feature Request to add this product feature. Note that an feature request is exactly that, a request. There is no committed date for this request from the Endpoint Encryption Product Management team, nor from the Endpoint Encryption Engineering team at this time.

 

Please be sure to refer back to this document periodically as any changes to the status of the request will be reflected here.