iOS 7 Devices No Longer Managed By MDM

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Article ID: 158484

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Updated On:

Products

Mobile Management

Issue/Introduction

Upon enrolling iOS 7 devices into Symantec Mobile Management, the device loses its MDM enrollment profile and is no longer managed.  If the user opens the SMM agent on the device, it prompts them to enroll again.

 

Cause

The upgrade to iOS and the SMM agent changes how a device is uniquely identified.  Please refer to www.symantec.com/docs/TECH209766 for more information.

The missing UDID identifier information for the device and the device resource on the server do not match.  This problem occurs when the device was upgraded to iOS 7 before:

Also, upgrade of the SMM agent to 7.6 / 1.0.5025 from any prior agent will force the device agent to be reset.  This new 7.6 / 1.0.5025 agent will only work with a new device ID format and enrolled iOS 7 devices are reset when upgraded to this agent.

Resolution

To resolve this issue:

  1. Make sure all devices have installed an iOS 7 compatible SMM agent.  Please see www.symantec.com/docs/TECH210048
  2. Make sure the SMM point-fix for iOS 7 device support has been correctly applied.  Please see www.symantec.com/docs/TECH209914

For each iOS 7 device affected by this behavior, you must delete its device object and re-enroll it.

  1. On the device, remove the MDM enrollment profile and reset the SMM device agent.
  2. Delete the corresponding device from the SMP console.
  3. Using the new iOS 7 compatible agent, re-enroll the device installing the new MDM profile.

 


Applies To

Symantec Mobile Management 7.2 SP 2.1 for SMP

iOS 7

Apple AppStore Agent 7.6

In-house Agent 1.0.5025