Restricting task service on the Notification Server to enhance performance

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Article ID: 158458

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Updated On:

Products

Management Platform (Formerly known as Notification Server)

Issue/Introduction

When the Notification Server is set up to manage task for hundreds (or thousands) of client machines, the tasks don't process in a timely manner and performance in other areas may be affected.

Cause

When the Notification Server is set up to manage task for more than 100 computers, performance will be affected.

Environment

ITMS 7.6, 8.0, 8.1

Resolution

1.Go to Settings > Notification Server > Site Server Settings > Settings > Task Service > Settings > Task Service Settings.

2. Clone the existing Task Service Settings policy and change the target to all site servers except the NS. To change the target, A) Delete the original one, B) Choose Apply to > Computers, C) Add rule to exclude resources not in Filter Computers with Task Services Installed, D) Add rule to exclude computers in Computer list [NS name]. E) Update results, click OK, and then save changes. Note: Nothing else changes for this policy.

3. Clone the Task Service Settings policy again, this time changing the target to only the NS. Adjust the number of "Maximum Computers to manage per Task Server" to 100, and remove the check mark next to "Allow maximum computers to be exceeded if a computer cannot connect to any other server".

4. Make sure both of these cloned policies are turned on and the original policy is turned off.