KNOWN ISSUE: Task Server not usable after uninstall/reinstall on a remote site server

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Article ID: 158436

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Updated On:

Products

Management Platform (Formerly known as Notification Server) Task Server

Issue/Introduction

Customer reported that he found that uninstall and reinstall of Task service left task server in an unusable state. Missing virtual directories

Steps to duplicate:
1. Install Remote Task server.
2. Customer removes remote Task Server by launching TS setup msi and selecting "remove"
3. Open IIS admin and browse the default web-site: Altiris\ClientTaskServer web-directory still present.
4. Task Server installed again to the computer.
5. Task Server setup completed, Task Server services are running, but Task Server virtual directory is not created in IIS.

Expected: TS uninstall should remove this directory.

Cause

Known Issue. Task Server setup detects that web-directory "already exists" and skip it's creation.Existence of this directory will not create issue for the new Task Server installs. However, if the directory is removed manually then new Task Server install will result in a non-functional remote task server, as Task Server setup will not be able to recreate web-site.


 

Resolution

This issue has been reported to the Symantec Development team. This issue should be fixed in a later release.

Workaround: create web-site manually and restart Task Server services.


Applies To

ITMS 7.1 SP2
ITMS 7.1 SP2 MP1
ITMS 7.5