Users Having Problems Logging into the ServiceDesk Portal and Not Able to view Incidents

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Article ID: 158430

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Updated On:

Products

ServiceDesk

Issue/Introduction

 Users are having problems logging  into the ServiceDesk portal and are not able to view incidents

User Error:

License check failed for this request. Either you do not have permission to access this content or your license usage has exceeded the available number of licenses

 

Error in Logs:

Error,Wednesday, September 18, 2013 9:59:21 AM,[global] Error when posting the heartbeat

[global] Client Host Information:

[global] IP: 10.1.14.111

[global] HostName: 10.1.14.111

[global] Browser: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.3; .NET4.0C; .NET4.0E; Zune 4.7)

[global] -- error.ToString() --

[global] System.ArgumentException: An item with the same key has already been added.

[global]

[global] Server stack trace:

[global]    at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)

[global]    at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)

[global]    at System.Collections.Generic.Dictionary`2.Add(TKey key, TValue value)

[global]    at LogicBase.Core.Licensing.New.WorkflowLicensingEngine.get_SclProviders()

[global]    at LogicBase.Core.Licensing.New.WorkflowLicensingEngine.GetLicenseStatusForServiceContext(String serviceContextName)

[global]    at LogicBase.Core.Licensing.New.WorkflowLicensingEngine.GetConcurrentUseLicenseCountForServiceContext(String serviceContextName)

[global]    at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& outArgs)

[global]    at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg, Int32 methodPtr, Boolean fExecuteInContext)

[global]

[global] Exception rethrown at [0]:

[global]    at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)

[global]    at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)

[global]    at LogicBase.Core.Licensing.New.WorkflowLicensingEngine.GetConcurrentUseLicenseCountForServiceContext(String serviceContextName)

[global]    at LogicBase.Ensemble.Reports.ProcessUserHeartBeatService.<>c__DisplayClass6.<PostUserHeartBeat>b__2()

[global]    at LogicBase.Framework.Utilities.RemotingHelper.<>c__DisplayClass1`1.<CallWithRetry>b__0()

[global]    at LogicBase.Framework.Utilities.RemotingHelper.CallWithRetry(Action func)

[global]    at LogicBase.Framework.Utilities.RemotingHelper.CallWithRetry[T](Func`1 func)

[global]    at LogicBase.Ensemble.Reports.ProcessUserHeartBeatService.PostUserHeartBeat(String sessionID, String userID, String ipAddress, String processID, String originator, String description)

 

Cause

 Duplicate License files in the license folder

Resolution

Stop IIS and the Symantec Workflow Service. Go to Program Files/Symantec/Workflow/Server Extensions/Plugins folder and remove all files except the current SD.Licensing.dll file. If there are any subfolders in this folder be sure there are no license files stored there and if so move them to another location. Restart IIS and the Symantec Workflow Service.

Applies To

 ServiceDesk 7.5