Error: System.Net.WebException: The remote server returned an error: (401) Unauthorized - when attempting to open /Altiris/NS/Services/NSConfigurationWebService.asmx

book

Article ID: 158394

calendar_today

Updated On:

Products

Management Platform (Formerly known as Notification Server)

Issue/Introduction

After the initial framework of an SMP 7.1 installation is completed the database and configuration must be performed. But the configuration process fails.

Entries similar to the following are seen in the NS logs:
 
* Description: Initializing WebService (NSConfigurationWebServiceProxy) at Url: http://servername.domain.com/Altiris/NS/Services/NSConfigurationWebService.asmx
*  Description: Exception encountered while verifying webservice: System.Net.WebException: The remote server returned an error: (401) Unauthorized.
   at System.Net.HttpWebRequest.GetResponse()
   at Symantec.Installation.WebServiceFactory.ServiceAvailable(Type t, String webServiceRootUrl)

Cause

 There were two “A” record entries in DNS which resolve the server to two different host names:

 
servername.domain.com
servername.pdp.domain.init.com
 
The first second entry was the actual FQDN of the server. The first one was an alias. Therefore the installation process was first given “servername.domain.com” as the FQDN to which to attempt to call the NSConfigurationWebService.asmx page. This caused the server to construct an authentication token as if it was attempting to access another server and not its self.
 
A test was performed to see if this condition existed by opening IE (while logged on as the SMP service account) and attempted to access the page using the two different FQDN records
 
http://servername.domain.com/Altiris/NS/Services/NSConfigurationWebService.asmx {The result was being challenged to authenticate. Even if given the proper credentials it did not give access to the page}
 
http://servername.pdp.domain.init.com/Altiris/NS/Services/NSConfigurationWebService.asmx   {Access to the configuration portal was immediately granted}

Resolution

Changed the value of the following two registry strings to “servername.pdp.domain.init.com” and attempted the reconfiguration of the platform in SIM

 
HKLM\Software\Altiris\AIM\Configuration\NSConfiguration
 
NSWebSiteCustomHost
NsWebSiteHost
 
 
Also changing the record for the correct FQDN to use from an “A” record to a “C” record (in DNS) would probably also correct the problem.

Applies To

Symantec Management Platform 7.1 SP2 MP1