Re-installation of corrupted ActiveX controls is not working properly

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Article ID: 158389

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Updated On:

Products

Management Platform (Formerly known as Notification Server)

Issue/Introduction

If for some reason customer have installed ActiveX controls, but the binaries were not registered - installation of AltirisNSConsole.cab will continuously appear.
Re-installation of corrupted ActiveX controls is not working properly. A prompt for cab installation appears but even after selecting "install" of the control it is not actually installed and prompted for installation after refreshing same page. Every page you visit in the Console, if it is not Silverlight-based, you may be prompted _again_ to install the AltirisNSConsole.cab control.

Steps to duplicate:
1. Install ITMS
2. Open the SMC for the first time
3. When Installation of AltirisNSConsole.cab appears, press "install" button
4. Open Another page instance for Settings>Notification Server>Hierarchy

Result: Installation of AltirisNSConsole.cab appears again.

Cause

Known Issue. It looks like IE checks for existence if dll of requested version before installing new one from the cab, but doesn't check that dll was actually registered in the registry.

Resolution

This issue has been reported to the Symantec Development team.

Current Solution:
Either manually register problematic dll file through regsvr32, or go to C:\Windows\SysWOW64 folder on the machine where IE is opened, delete following files:
1. AeXMenuCtrlLib.dll
2. AeXNSConsoleUtilities.dll
3. AeXNSPkgDLLib.dll
4. AeXScheduleMgr.dll
5. AeXTreeCtrlLib.dll


and re-open the Console.


Applies To

ITMS 7.5