Error "No email or phone number options are available to receive a temporary security code for sign-in" during SSP sign-in
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Error "No email or phone number options are available to receive a temporary security code for sign-in" during SSP sign-in

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Article ID: 158333

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Updated On:

Products

VIP Service

Issue/Introduction

VIP end-users receive the following error when logging into the VIP Self-Service Portal:

No email or phone number options are available to receive a temporary security code for sign-in.

Or, the My VIP Portal:

No email options are available to receive an enrollment code. Contact your organization's administrator for assistance.

 

Cause

Navigate to VIP Manager > Policies > Components > ' My VIP and VIP Self Service Portal'.  When the option "Require second-factor authentication for first-time access" is set to YES and a user does not have a credential ID, a temporary security code is delivered through out-of-band (OOB) to Voice, SMS, or email. If none are available for the user, the code cannot be delivered and this error is generated.  

 

Resolution

Switching this option to NO will resolve the issues by allowing users without a credential ID to access the portal.  This method is less secure.

If the option is set to YES, follow the instructions in the VIP Enterprise Gateway guide for configuring out-of-band attributes.

If using a 3rd-party IdP for portal access, refer to that guide.

note: SMS and Voice credential types can be used as the out-of-band method for delivering a temp security code. If the user is assigned one or more of these credential types, they will appear in the list of OOB delivery options.