Batch File does not Work in Managed Software Delivery Policy or Quick Delivery Task but Runs Fine Manually
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Batch File does not Work in Managed Software Delivery Policy or Quick Delivery Task but Runs Fine Manually

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Article ID: 158328

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Updated On:

Products

Software Management Solution

Issue/Introduction

When deploying a software package with a batch file to run command lines the run does not succeed with Software Management Solution. However, when the batch file is run manually on the same client machine it succeeds.

Environment

ITMS 7.x, 8.x

Cause

This has occurred for the following situations:

  1. The batch file contains commands such as assoc that cannot successfully run without an open command window but the software delivery task or policy is configured to not show a command window.
  2. The batch file must be run with certain user credentials (usually to access certain folders) but the software delivery task runs it with the SYSTEM account.

Resolution

The following solutions address the previously described situations:

  1. In the Managed Software Delivery (MSD) policy or Quick Delivery task open Advanced options and go to the Run tab. Set the Display window: option to "Minimized" rather than "Hidden." It may also be necessary to enable the setting Allow user to interact with installing software.
  2. In the Managed Software Delivery (MSD) policy or Quick Delivery task open Advanced options and go to the Run tab. Under Run as select Current logged-on user or select Specific user: and fill in the needed credentials.

To test if a MSD policy will now work save changes then go the client machine's Symantec Management Agent GUI and open Settings. Click Update Configuration then go to the Software Delivery tab, select the policy and then click on the policy under Application Tasks to run it. To test if a Quick Delivery task will now work save changes then click Quick Run and run the task on a test machine.