Maintenance Windows are not being displayed in the agent Maintenance Window tab.

book

Article ID: 158294

calendar_today

Updated On:

Products

Management Platform (Formerly known as Notification Server)

Issue/Introduction

One or more Maintenance Windows have been assigned to a computer but the MW is not showing in the "Maintenance Windows" tab. 

The Client Policy XML contains references to an enabled MW policy but it is not loaded or displayed. The sub agents know that there is a MW policy but they do not follow it. Therefore they do not run items such as Patch Management.

 

In the agent logs was found the following warning (excerpt):

 

Module: AeXNSAgent.exe
Source: MaintenanceWindowManager
Description: Error in SetSchedules: The parameter is incorrect. (-2147024809)
 
 

 

Cause

The Maintenance Window policy had several windows defined. The windows were configured for "Year (date view)".  At least one month was selected but there were no dates selected. As a result the XML content of the policy contained the following in the "schedule" section:

 
     <triggertype="YearlyByDate" exact="True" at="10:00:00" duration="02:00:00" months="3" dates="26" />
     <triggertype="YearlyByDate" exact="True" at="10:00:00" duration="02:00:00" months="4" dates=" " />
     <triggertype="YearlyByDate" exact="True" at="10:00:00" duration="02:00:00" months="5" dates="16" />
     <triggertype="YearlyByDate" exact="True" at="10:00:00" duration="02:00:00" months="6" dates="27" />
     <triggertype="YearlyByDate" exact="True" at="10:00:00" duration="02:00:00" months="7" dates="16" />
     <triggertype="YearlyByDate" exact="True" at="10:00:00" duration="02:00:00" months="8" dates="11" />
 

The "dates" tag in one or more of the schedules had no value selected. Therefore, when the schedule parameter is passed into the agent to load it, it receives a value it could not use.

In this example it was month 4

 

 

Resolution

Checking at least one date in the month where none was selected will resolve the problem. It is not clear how this condition occurred since the Maintenance Window UI does not allow a policy to be saved unless at least one value is selected. 

At least 7.1 SP2 MP1.1 v5 or later.


Applies To

Symantec Management Platform 7.1 SP2 MP1.1