Symantec Endpoint Protection Manager will not update definitions when another application on the system is listening on port 9090.

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Article ID: 158229

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Updated On:

Products

Endpoint Protection

Issue/Introduction

The Symantec Endpoint Protection Manager (SEPM) will not update definitions correctly after running LiveUpdate, although LiveUpdate itself returns no error when run from the console and may report that definitions are updated. Further investigation of the system that the SEPM is running on indicates that another software application is listening on TCP port 9090.

The error for this issue will be reported in the SesmLu.log and will appear similar to the following:

07/08 06:50:31 [1bc8:1550] ERROR      sesmIPSdef32 ProductUtil Initialize Tomcat server xml file failed.
07/08 06:50:31 [1bc8:1550] ERROR      sesmIPSdef32 SesmLu InternetOpenUrl failedat SesmLu.cpp[1570]
07/08 06:50:31 [1bc8:1550] ERROR      sesmIPSdef32 SesmLu Failed to notify SESM servlet of new LiveUpdate package.at SesmLu.cpp[1322]
07/08 06:50:31 [1bc8:1550] ERROR      sesmIPSdef32 SesmLu Failed to notify servlet of new content.at SesmLu.cpp[1164]

Cause

The SEPM is expected to be listening on port 9090 to full process its definitions. If a conflicting application is using the port instead, this process cannot complete correctly. Although definitions are downloaded, they are not properly inserted into the database.

Resolution

This issue can be resolved by following one of the solutions listed below:

  1. Rerun the management server configuration Wizard and set the SEPM to listen on a port other than 9090.
  2. Reconfigure the conflicting application to use a port other than 9090.
  3. Remove the conflicting application from the system.

Applies To

SEPM version 12.1 RU2. Remote MS SQL Database.

In this instance the conflicting application was a third party log collector tool running on port 9090.