Error "Server Error in '/Altiris/application_name' Application occurs when accessing a specific area in the Symantec Management Platform Console

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Article ID: 158159

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Updated On:

Products

Mobile Management Management Platform (Formerly known as Notification Server) IT Analytics Asset Management Solution CMDB Solution

Issue/Introduction

When accessing any part of the Symantec Management Platform Console, going to a specific area results in a critical server error/runtime error.

The affected area will be listed in the main error. This error can occur for any Altiris product, however.

Server Error in '/Altiris/<product name>' Application.
--------------------------------------------------------------------------------

Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".


<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>


Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.


<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>

Cause

A critical server error has occurred and is being viewed on a workstation. The error itself is not the real error, however, but indicates in the "error" messages being viewed remotely have been disabled (by default) for security reasons.

Resolution

This is not the real error as it is being withheld. To see and then troubleshoot the real error, reproduce the error on the Altiris server, or, follow the error's instructions to enable remote viewing of critical server errors and then reproduce the error on a workstation.

Once the real error has been identified, search the Symantec Knowledge Base for the specific error message to begin troubleshooting. Common examples include:

Error "Server Error in 'Altiris/AssetContractCommon' Application" occurs when trying to view or edit an asset
http://www.symantec.com/business/support/index?page=content&id=TECH198042

HTTP 404:Server Error in /Altiris Application (Silverlight issue)
http://www.symantec.com/business/support/index?page=content&id=tech196894&actp=search&viewlocale=en_us&searchid=1372444164305

Server Error on viewing Mobile Management policies
http://www.symantec.com/business/support/index?page=content&id=tech200221&actp=search&viewlocale=en_us&searchid=1372444216720