SEP client does not update definitions

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Article ID: 158152

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Updated On:

Products

Endpoint Protection

Issue/Introduction

Symantec Endpoint Protection (SEP) clients do not update definitions.

The issue has already been resolved by clearing corrupted definitions per the following article:

Potential Symantec Endpoint Protection content definition corruption

http://www.symantec.com/business/support/index?page=content&id=TECH92043

However files in the folders have "Access Denied"

Access Denied when accessing/deleting a definition file.

Cause

LANDesk Remote Control Application has locked the access to Symantec liveupdate content definition files.

It can be any application that is able to lock a process by accessing it for that instance, for example - explorer.exe.

Resolution

Identify the exact files that are being locked. After identifying the affected files, for example definition.dat.

Run Process Explorer as Administrator > Find > Find Handle or DLL.

Search for definition.dat, note all processes and PID that are accessing the file (LANDesk is just an example of a process that can lock a file)

Kill any PID/process accessing the affected files.

A possible permanent solution for this is to contact LANDesk Support and/or patch/upgrade to latest version of this software if it is a 3rd party software.


Applies To

Symantec Endpoint Protection 11.x and 12.1