Known Issue: Changes lost in the justification if you want to edit it before confirming

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Article ID: 158094

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Updated On:

Products

ServiceDesk

Issue/Introduction

While reassigning a ticket if we type some justification then try to edit it before confirmation the typed text is missing. Here are the steps to reproduce the issue:

1) Open an incident
2) Click on Reassign Incident
3) Type a justification and reassign it to a user
4) If we want to edit the justification at this point and we click on "Edit" button
5) It returns to the previous screen however the justification is missing.

Cause

Known Issue: The path for Edit option is re-tracked in the Incident Management workflow project

Environment

ServiceDesk 7.1

Resolution

Edit the workflow project for Incident Management.

Please follow the below steps or refer to the attached word document for steps with the screenshots:

  1. Open the Incident.management project.  Then select Initial Diagnosis Model.
  2. Double click on Initial Diagnosis then click on Interaction setup tab.
  3. Click on Reassign Incident and Edit. Then click on the eclipse for Dialog Model.  
  4. Right click on Confirm Escalation request and select Edit Component. In the Go Back Path select (none).
  5. Edit option will be visible now. Connect the line from Edit option to User Specify Escalation, click on OK to save the Project and publish it.