Unable to decrypt email with error "Key not found" (PGP/Outlook Integration)

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Article ID: 157992

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Updated On:

Products

Desktop Email Encryption

Issue/Introduction

When trying to lookup keys to decrypt an email, you receive a "Key not found" error (in reference for the key needed to decrypt the email).

"Key not found" as reported by PGP/Symantec Encryption Desktop w/Outlook Email integration.

 

Before going further, make sure that a) the user who's key appears to be missing exists and b) that the same user has a key on the server that can be downloaded and accessed by the user who cannot decrypt the message.

Cause

Since PGP Universal Server 3.2.1 MP3 was released, there is now an option to allow email for a group policy that wasn't in previous versions.   When customers upgrade their Universal Server to 3.2.1 MP3 or higher from an older version, they can run this issue.

Resolution

You will need to enable email for the group policy of the user who is unable to decrypt messages.

 

1. Log into the Universal Server web UI as a Super User.

2. Go to the following location:

Consumers --> Consumer Policy --> Specific Policy --> Keys (Edit button) --> Options --> Product Usage

3. Make sure the box is checked and enabled for "Allow users to receive encrypted email".

4. Click the "Save" button

 

Wait about 3 minutes and then try sending an encrypted email message to that user.  They should now be able to decrypt a message automatically, whereas before they received the "Key not found" error.

 

This is the box that needs to be checked/enabled:


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