Unable To Enroll Device With New Symantec Mobile Management iOS Agent

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Article ID: 157970

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Updated On:

Products

Mobile Management

Issue/Introduction

After installing a new Symantec Mobile Management iOS Agent, you are not able to enroll the device into your SMM environment.  Older versions of the SMM agent enroll as expected.

After you enter the correct email address or enrollment URL, you receive an error message:

"Login failed - Entered the wrong enrollment url?"

Cause

The SMM iOS agent 1.0.4814 and newer agents are not compatible with Symantec Mobile Management 7.1 SP1 and earlier environments. 

On your Notification server, you can verify the SMM release by opening the Symantec Installation Manager.

On the iOS device, you can verify the agent build by going to "Settings" --> "Mobile MGMT" (near the bottom of the left pane).

 

Resolution

There are two workarounds that can be implemented:

  1. Upgrade your SMM environment to a newer or latest release.
  2. Compile an older version of the SMM iOS in-house agent framework, distribute, and enroll using this agent.  Please contact Symantec Support to obtain older agent framework.

 


Applies To

Symantec Mobile Management 7.1 SP1

Symantec Mobile Management Agent for iOS 1.0.4814 and greater.