Symantec Web Gateway (SWG) Virtual Edition randomly displays browser errors when deployed in proxy mode

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Article ID: 157891

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Updated On:

Products

Web Gateway

Issue/Introduction

Users experience random browser errors when connectin to websites through Symantec Web Gateway (SWG) Virtual Edition deployed in Proxy mode.

Cause

SWG Virtual Edition in Proxy mode requires two separate subnets for the Management and Proxy / LAN interfaces. When these 2 subnets interconnect due to a network misconfiguration, the traffic may be handled by the wrong SWG interface at random times. This creates connection interruptions that cause the browser to display an error. The error would depend of the browser and version used.

Resolution

SWG must be deployed according to the documentation. Please make sure the Management and Proxy networks do not share the same switch or hub. If interconnected, this should occur via a router.

A verification of proper network connectivity can be done by analysing the traffic between the client machine and SWG.

Other conditions that can cause unspecific browser errors can be found here:

The web browser displays an error while traffic is configured to go through Symantec Web Gateway (SWG)