Symantec Management Agent Installation fails on Windows Machine. Failed to run action:InstallCoreAgentDll
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Symantec Management Agent Installation fails on Windows Machine. Failed to run action:InstallCoreAgentDll

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Article ID: 157876

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Updated On:

Products

IT Management Suite

Issue/Introduction

Symantec Management Agent Installation fails on a Windows x64 machines.
Errors in the Agent install logs read:
"Install failed. Error message: Failed to run action: InstallCoreAgentDll"

 

Install failed. Error message: Failed to run action: InstallCoreAgentDll

 

Environment

ITMS 8.x

Cause

If WinPE 32 bit preboot OS is used to backup a x64 bit managed client, after backup completion, a bug in Deployment Solution code adds a registry in "HKLM\Software\Altiris\Altiris Agent" hive. Resulting the hive completely inaccessible.

 

Resolution

If you are already observing the error follow the procedure below to remove bad registry and reinstall agent on the machine.
 
Remove bad registry key on a machine you have physical access to
 
a. Copy the 'GHRegEdit64.exe' file from '\Program Files\Altiris\Deployment\Imaging\ghost\x64' to the 'NSCap' Share on the NS (Use GHRegEdit32.exe if the client with the error is a x86 machine. This is found under '\Program Files\Altiris\Deployment\Imaging\ghost\x86')
 
b. Go into the windows repair command prompt (push F8 while windows is loading -> Choose 'repair computer' -> Choose 'Command Prompt')
 
c. Run 'wpeinit' to enable the networking before running the commands
 
d. Run 'net use y: /user:<Domain\User> \\<SMP-FQDN>\NSCAP <Password-for-User>'
 
e. Then Run 'y:\GhRegEdit64.exe delkey D:\Windows "HKLM\Software\Altiris\Altiris Agent"'
 
f. After this completes reboot the machine back into Windows and verify the registry is accessible
 
g.Try installing the Management Agent once again and this time it should work
 
 
 
Remove bad registry key on a remote machine using Deployment Solution
 
a) Copy the 'GHRegEdit64.exe' file from '\Program Files\Altiris\Deployment\Imaging\ghost\x64' to the 'NSCap' Share on the NS (Use GHRegEdit32.exe if the client with the error is a x86 machine. This is found under '\Program Files\Altiris\Deployment\Imaging\ghost\x86')
 
b) Assign a "boot to" task to the managed client and let it run so that it boots to automation
 
c) Once the machine is in WinPE use a run script task and run the following script against the client:
------------------------------------------------------------------------------------ 
net use y: /<Domain\User> \\<SMP-FQDN>\NSCAP <Password-for-User> 
y:\GhRegEdit64.exe delkey D:\Windows "HKLM\Software\Altiris\Altiris Agent" 
-----------------------------------------------------------------------------------
 
d) Schedule a "boot to" task to reboot to production
 
e) Once back in Windows check whether the registry is now accessible.
 
f) Re-push install agent from SMP console and wait till status changes to success.