KNOWN ISSUE: After Customer Survey task timeout, the task is removed but Survey status will stay at 'Survey Sent' with 50% completion.

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Article ID: 157849

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Updated On:

Products

ServiceDesk

Issue/Introduction

After a Customer Survey task reaches a time out, the task is removed but the status will still be reflected as 'Survey Sent', with completion percentage at 50%.

Cause

Product Defect.

Timeout actually does work but the component that should capture the timeout path is misconfigured.

Resolution

This issue is fixed in ServiceDesk 7.6.

FIX:

As the Customer Survey project (SD.CustomerSurvey) is open for modifications, this issue can be fixed by modifying the project.

  1. Open SD.CustomerSurvey project in Workflow Designer
  2. In Primary model Edit the Catch Timeouts component at the top right
  3. Change Path Name Variable setting from "timed out" to "ComponentPath"
  4. Save and Publish the modified project.

As with any project modifications, this should be tested before putting it into production.

 

Applies To

 

ServiceDesk 7.5