The "Allow user to defer up to a total of" option on a Managed Software Delivery policy does not always work.

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Article ID: 157831

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Updated On:

Products

Software Management Solution

Issue/Introduction

On a Managed SWD policy, the "Allow user to defer up to a total of" option does not work if the Symantec Management Agent's "Warning Countdown duration" timer is set to anything other than the default of five minutes.

There is a problem if the MSD Policy's "Allow user to defer up to a total of" option is selected and the SMagent "Warning Countdown duration" timer is set to anything other than the default of five minutes.

The SMAgent “Warning Countdown duration” timer is found under "Settings > Agents/Plug-ins > Symantec Management Agent > Settings > Symantec Management
Agent Settings – Targeted > User Control tab".

The MSD policy's "Allow user to defer up to a total of" option is found on the policy under "Policy Rules/Actions > Software tab > Advanced options button > Run tab > User run conditions section".

First test:
I left the SMAgent “User Control” “Warning Countdown duration” timer set  to the default 5 minutes and I set the MSD policy “Advanced options > Run tab > select Prompt user before running > select Allow user to defer up to a total of” timer to 20 minutes.
When the client starts to run the policy the deferral pop-up gave the options to defer for 5, 10 or 15 minutes. I selected 5 minutes.
The next pop-up gave the same options to defer for 5, 10 or 15 minutes. Again, I selected 5  minutes.
The next pop-up gave the options to defer for 5 or 10 minutes. Again, I selected 5 minutes.
Then next pop-up gave the option to defer for 5 minutes. Again, I selected to defer for 5 minutes.
The next pop-up did not give an option to defer but just warned me that the policy would run in 5 minutes and it started the countdown.
So I selected four options to defer for five minutes each for a total of 20 minutes. This is what the policy was set to allow.

Second test:
I then set the “Warning Countdown duration” timer to 10 minutes. I left the “Allow user to defer up to a total of” timer set to 20 minutes.
The first deferral pop-up gave the options to defer for 5, 10 or 15 minutes. I choose to defer for 5 minutes.
The next pop-up gave the same options to defer for 5, 10 or 15 minutes. Again, I selected 5 minutes.
The next pop-up gave the options to defer for 5 or 10 minutes. Again, I selected 5 minutes.
The next pop-up gave the option to defer for 5 minutes. Again, I selected to defer for 5 minutes.
The next pop-up gave the same option to defer for 5 minutes. Again, I selected to defer for 5 minutes.
The next pop-up gave the same option to defer for 5 minutes. Again, I selected to defer for 5 minutes.
The next pop-up gave the same option to defer for 5 minutes. Again, I selected to defer for 5 minutes.
The next pop-up gave the same option to defer for 5 minutes. Again, I selected to defer for 5 minutes.
The next pop-up gave the same option to defer for 5 minutes. I then stopped the test.
Even though the “Allow user to defer up to a total of” timer was set to 20 minutes I was able to defer for 45 minutes before manually stopping the test.

 

None

Cause

A permanent fix has been provided in 7.1 SP2 MP1 V6. (See HOWTO81832)

Resolution

A permanent fix has been provided in 7.1 SP2 MP1 V6. (See HOWTO81832)


Applies To

ITMS 7.1 SP2 MP1 roll-up v3